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| ERTLab | > | 1. Introduction | > What is ERTLab?

What is ERTLab?

| << | >> |

ERTLab is the Resistivity/IP inversion software that offers full three-dimensional
modeling and inversion. Its numerical core, based on tetrahedral Finite Elements,
allows the user to input complex topographic information and to invert data-sets collected
using surface, borehole or surface-to-hole array configurations.
ERTLab integrates a numerical core, a visualizer and a sequencer in three distinct
environments. The reliable and robust algorithm for 3D resistivity inversion assures
accuracy and convergence, even when high levels of noise are present in the data-set.
The high-performance graphics environment provides real-time visualization of volumes
and sections. The Sequencer provides an easy-to-use tool for the creation of 2D and 3D
arrays/schedules of electrical resistivity measurements.

Shortcuts
See also:
Forward Modeling
Tutorial

Typical uses include:
3D inversion of field data collected along 2D profiles, three-dimensional surface
grids, boreholes, surface-to-hole arrays, or any 2D or 3D four-electrode array.
Sequence generation: a practical toolkit permits easy development of 2D and 3D
surface or cross-hole sequences.
Survey design: the tetrahedral Finite Element 3D forward modeling module may
be used to generate simulations over synthetic user-defined resistivity models.
Advanced 3D Viewer : using the 3D graphical environment inverse and forward
models may be visualized in a variety of ways, including sections, volumes and
isosurfaces. These may be spun and re-oriented in real-time. You can add labels,
and change color mapping by choosing resistivity/conductivity values or using linear
or logarithmic colorbars.

|© 2006 Geostudi Astier srl and Multi-Phase Technologies LLC|

2

| ERTLab | > |

1. Introduction | > The ERTLab System

The ERTLab System

| << | >> |

The ERTLab System consists of three main components:

A practical tool for the creation of 2D and 3D
arrays/schedules of electrical resistivity measurements.

The numerical core for forward and inverse modeling.

A graphical environment to display resistivity and IP
models.

.
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| ERTLab | > |

1. Introduction | > Installation guide

Installation guide

| << | >> |

The full release of ERTLab requires a dongle. The dongle is a hardware-based security
device that attaches to the USB port of your computer. To allow your OS to work with
dongle, you need to install the appropriate drivers. A demonstration version of the
code is available.
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| ERTLab | > | 2. Working Environment | > The ERTLab System

ERTLab Overview

| << | >> |

This form provides a guide to the ERTLab Solver working environment. If the program
has not yet been installed please follow the procedures for installation. At any time you
may review the glossary of terminology and the command reference.
The ERTLab Solver is organized in a series of menus. A toolbar is available for easy
navigation through basic tasks. The Explorer Window provides a more detailed graphical
navigation method. The ERTLab Solver is subdivided into a series of workspaces
designed for the tasks typically encounted in ERT. These are:
1. Electrodes Workspace
The electrodes workspace provides a listing of electrode locations. Editing of locations,
and type (borehole, surface and remote) are available. The electrodes can be viewed in
3D.
2. Data Quality Control Workspace
The Quality control workspace provides reciprocal checks, thresholds and simple
selections to ensure that only high quality data are used for inversion.
3. Mesh and Resistivity/IP model workspaces
The mesh and resistivity / IP model workspaces provide user-friendly menus to help
with creation of the mesh, forward models and inverse starting models.
4. Inversion Workspace
The inversion workspace presents a parameter list, data entry and start and stop
buttons for inversion.
5. Forward Modeling Workspace (Survey Design)
The forward modeling workspace presents a parameter list, data entry and start and
stop buttons for forward modeling (hypothesis testing and survey design).
6. Sensitivity Workspace
The sensitivity workspace provides the user the tools to perform the sensitivity analysis
for each quadrupole.
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| ERTLab | > | 2. Working Environment | > Menus

Menus

| << | >> |

The system menu provides access to operations that are available from the toolbar, the
Explorer Window and the workspaces. The following items are available:

File - Use the file menu items to start a New Project (Data Inversion or Survey
Design) or to Exit the program. Survey design is used for forward modeling to test
hypotheses and determine the electrode distributions and array schedules that will best
meet the needs of your project.
Once a project type (Inversion of Survey Design has been chosen) you have access to the
following menus:
View - Use Explorer Window to show the navigation bar in the right side of the
screen, use Inversion Progress Plots to show/hide the graphics of the inversion
status during an inversion session.
DataSet - Use the DataSet items to access the Electrodes, Quadrapoles and
pseudo-plots workspaces.
Mesh - Use Make Mesh to display the mesh workspace; use Make Resistivity/IP
model to access the model workspace and to create your own resistivity/IP starting
models. The Export Mesh and Resistiviy Model and Export Mesh and IP Model
items permit export of the full mesh (foreground + background regions) and the
Rho/IP model (initial or inverted). The Import Mesh and Model item permits import
of a complete mesh (foreground + background) and resistivity model that was
previously saved using the Export function and to use them in the current
inversion/survey design session. The Load Resistivity Model and Load IP Model
loads only the Rho/IP features (background and anomalies) from a configuration
(.cnfg) file.
Tools - Use the Tools menu item to launch ERTLab 3D Viewer (or to Run a 3D Viewer
script file) and to launch the ERTLab Sequencer.
Options - Use the Options menu to set the path for the 3D Viewer and Sequencer (by
default in the Application directory) and to set the background color of the workspaces.
Help - This item provides access to ERTLab help files and the About dialog.
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| ERTLab | > | 2. Working Environment | > Toolbar

Toolbar

| << | >> |

The toolbar provide quick access to the follwing operations:

Open a new Data Inversion project (launch the Data Inversion Workspace).

Open a new Survey Design project (launch the Forward Modeling Workspace).

Close the current project.

Display the Explorer Window on the right side of the screen.

Display the inversion progress graphics that show parameters describing
behaviour and progress of the inversion.

Launch the ERTLab 3D Viewer.

Launch the ERTLab Sequencer.

Launch help file.
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| ERTLab | > | 2. Working Envinroment | > Explorer Window

Explorer Window

| << | >> |

The Explorer Window is placed on the right side of the screen and provides easy access to
the workspace environments of the program. The workspaces and their dependent menus
are arranged in an intuitive tree with roots on the left and branches on the right. To move
from one environment to the other select the appropriate item from the menu. When the
Explorer Window is closed or hidden, it may be brought forward by selecting Explorer
Window from the View menu or by clicking the

Items:
1. Schedule
2. Data Quality Control
3. Mesh and Rho/IP
Model

button on the toolbar.

4. Data Inversion
(Forward Modeling)
5. Sensitivity Analysis

Items available in the Explorer Window are different depending on whether a Forward
(Survey Design) or Inversion project is in session. Since the forward menu is less
complicated, the inversion menu will be described. From the top to the bottom, we find
the following items:
Schedule
For a Data Inversion Project:
1. Import Syscal file provides access to a component for importing IRIS BIN files.
2. Data set (file name): appears after a Schedule has been input. This branch
provides direct access to the Data Quality Control Workspace for visualization of
electrodes, quadrapoles and measurements, quality control operations, and
generation of pseudo-plots of apparent resistivity and IP.
In Survey Design mode the Import Syscal file item is substituted by a Schedule Maker link
to the Sequencer module.
Data Quality Control
Visualization of electrodes, quadrapoles and measurements, quality
operations, and generation of pseudo-plots of apparent resistivity and IP.

control

Mesh and Resistivity/IP Model
1. Make Mesh: open the mesh workspace to generate or manipulate mesh settings
using a menu (rather than directly entering the settings in the Configuration
Settings).
2. Make Resistivity/IP Model: open the Model Workspace to build a resistivity or IP
model (assign background + insert anomalies). Anomalies are not usually inserted
for an inversion, however an appropriate background should be assigned.
Anomalies are typically used for forward modeling.
3. Export Mesh and Resistivity Model: export the generated mesh and resistivity
model including the background region.
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4. Export Mesh and IP model: export the generated mesh and IP model including
the background region.
5. Import Mesh and Model: import a mesh and a resistivity model that has been
saved using the export functions above.
6. Load Resistivity Model: load the frameword for a resistivity model (background
resistivity + anomalies) from a configuration file.
7. Load IP Model: load the frameword for an IP model (background IP +
anomalies) from a configuration file.
Data Inversion (or Forward Modeling for Survey Design)
1. DI workspace (or FM workspace for Survey Design): open the Data Inversion
workspace (or the Forward modeling workspace). This is the master window that
provides controsl for data input, saving output and running the models.
2. Forward solver set up: set up of the main forward parameters (pcg solver
tolerance, iterations, boundary conditions, ...).
3. Inverse solver set up (for Data Inversion only): set up of the main inversion
parameters (number of iterations, roughness, weights, ...).
Sensitivity Analysis
SA workspace: open the Sensitivity analysis workspace.
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| ERTLab | > | 2. Working Environment| > Data input and file formats

Data input and ERTLab file formats

| << | >> |

The ERTLab data format is evolving. Ultimately it will be flexible enough to permit
separate or combined loading of configuration, electrode, quadrapole (schedule or data)
and topography information. Currently the input schedule button expects al least
electrode locations and quadrapoles in a single file. Topography and configuration
information can be imported separately.
Working with ERTLab Solver the following files will be used:
Configuration files - (*.cnfg): text files containing the appropriate tags to
indicate configuration information. For specific format documentation please refer to
the Configuration tags section.
Schedule files - (*.schd): text files that contain location information for the
electrodes and a list of quadrapoles.
Data files - (*.data): the same of the schedule files, but with additional
information on field or calculated data-set (V/I, apparent resistivities, IP, standard
deviations, ...).
Topography files - (*.topo): text files that contain the x,y,z topography
information.
Viewer model files - (*.vwer): files containing the starting or inverted resistivity
(or IP) model with electrodes, mesh nodes, data values for each element and
quadrapoles. They may be viewed using the ERTLab Viewer.
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| ERTLab | > | 2. Working Environment | > | DATA INPUT | > What is a schedule file?

What is a schedule file?

| << | >> |

Schedule and data files are text files (extension .schd and .data) that contain location
information for the electrodes and a list of quadrapoles.
Electrodes must be identified in terms of both logical groups, called cables, and electrode
number in that group. For each electrode, X, Y, and Z location must be specified.
Additional columns are available. ZTerrain specifies the surface elevation above an
electrode, and the borehole / surface and remote flag specifies the electrode type
(1-borehole, 2-surface, negative for remote poles).
For inversion, the quadrapoles must have data values associated with each quadrapole.
For forward modeling, the quadrapole list is sufficient. For inversion the minimum data
required are measured resistances (V/I). A configuration header may be used to specify
the column ID for any other data that will be included. ERTLab control columns such as
the Skip flag are also implemented to indicate usage in the program. This permits ultimate
flexibility and independance from any single instrument output. For specific format
documentation please refer to the Schedule file format.

|© 2006 Geostudi Astier srl and Multi-Phase Technologies LLC|

11

| ERTLab | > | 2. Working Environment | > | DATA INPUT | > Schedule and data file format

Schedule and data file format

| << | >> |

ERTLab employs keywords (tags) to indicate subsets of a data file and configuration
information. In version one, the schedule file should contain electrode and quadrapole
information. Later versions will ultimately permit this information to be input from
different files or conversely other information such as topography and mesh configuration
may be recordable in the schedule file. Each keyword starts with the # symbol. The
comment character is !. Any information placed between ! and the end of a file line is
ignored. Blank lines are also ignored.
Electrode format
The Electrode format requires an #elec_start keyword
electrode listing and an #elec_end keyword to indicate the
In absence of further tags, the electrodes are loaded,
modeling workspace, on the basis of the I/O format
configuration settings list.

to indicate the start of the
end of the list.
in the Inversion or Forward
parameters specified in the

Electrodes input format can be included in the data file by using the appropriate
configuration tags. The configuration information may include:
#elec_no_cable, a flag indicating the presence of cable identifiers (1 present; -1 not
present);
#elec_cable_col, column identifier for the cable group (cable number);
#elec_id_col, column identifier for the electrode number;
#elec_x_col, column identifier for the electrode X location;
#elec_y_col, column identifier for the electrode Y location;
#elec_z_col, column identifier for the electrode Z location;
#elec_elev_col, column identifier for the electrode Z terrain elevation;
#elec_type_col, column identifier for the type of electrode.
At a minimum columns must include #elec_cable_col or cable number, #elec_id_col or
electrode number, #elec_x_col or X location, #elec_y_col and #elec_z_col for Y and Z
locations.
Flag -1 stands for information not present.
If the electrode type is not specified in the input file, ERTLab will derive it for each
electrode. "Remote" flags will be attributed to the cables having one or two electrodes. If
the electrode z terrain elevation is not specified in the input file, ERTLab will derive it for
each electrode.
The complete list of possible commands is documented in the example below:
!Electrodes input/output format
#elec_no_cable= 1
#elec_cable_col= 1
#elec_id_col= 2
#elec_x_col= 3
#elec_y_col= 4
#elec_z_col= 5
#elec_elev_col= 6
#elec_type_col= 7
#elec_start
1
1
1000
2
1
-1000
3
1
-100
3
2
-50
3
3
0
3
4
50
3
5
100
4
1
0
4
2
0
4
3
0
4
4
0
4
5
0
#elec_end

100
100
100
100
100
100
100
100
100
100
100
100

0
-5
0
0
0
0
0
-25
-20
-15
-10
-5

0
0
0
0
0
0
0
0
0
0
0
0

-2 !Remote surface electrode
-1 !Remote borehole electrode
2 !Five electrode surface cable
2
2
2
2
1 !Five electrode well
1
1
1
1

Data format
The Data format requires a #data_start keyword to indicate the start of the data listing
and a #data_end keyword to indicate the end of the list.
In absence of further tags, quadrupoles and data are loaded, in the Inversion or Forward
modeling workspace, on the basis of the I/O format parameters specified in the
configuration settings list.
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Data input format can be included in the data file by using the appropriate configuration
tags. The configuration information may include:
#data_id_col, column identifier for the quadrupole number;
#data_a_cable_col, column identifier for the TX+ (A) electrode cable number;
#data_a_elec_col, column identifier for the TX+ (A) electrode id number;
#data_b_cable_col, column identifier for the TX- (B) electrode cable number;
#data_b_elec_col, column identifier for the TX- (B) electrode id number;
#data_m_cable_col, column identifier for the RX+ (M) electrode cable number;
#data_m_elec_col, column identifier for the RX+ (M) electrode id number;
#data_n_cable_col, column identifier for the RX- (N) electrode cable number;
#data_n_elec_col, column identifier for the RX- (N) electrode id number;
#data_res_col, column identifier for field data resistance (V/I);
#data_ip_wind_col, column identifier for field data IP;
#data_std_res_col, column identifier for field data resistance standard deviation;
#data_std_ip_col, column identifier for field data IP standard deviation;
#data_calc_res_col, column identifier for calculated resistance (V/I);
#data_calc_ip_col, column identifier for calculated IP;
#data_calc_std_res_col, column identifier for calculated V/I standard deviation;
#data_calc_std_ip_col, column identifier for calculated IP standard deviation;
#data_appres, flag for data in terms of resistance V/I (1) or apparent resistivity (2);
#data_ip_scale, scale factor for IP data.
At a minimum columns must include the datapoint ID, the electrode ID's (cable and
electrode) for each of the four quadrapole electrodes (eight columns) and a resistance.
Flag -1 stands for information not present.
The example below shows a possible
#data_id_col= 1
#data_a_cable_col= 2
#data_a_elec_col= 3
#data_b_cable_col= 4
#data_b_elec_col= 5
#data_m_cable_col= 6
#data_m_elec_col= 7
#data_n_cable_col= 8
#data_n_elec_col= 9
#data_res_col= 10
#data_ip_wind_col= 11
#data_std_res_col= -1
#data_std_ip_col= -1
#data_calc_res_col= -1
#data_calc_ip_col= -1
#data_calc_std_res_col= -1
#data_calc_std_ip_col= -1
#data_appres= 1
#data_ip_scale= 1000.0
#DATA_Start
1
1
1
4
1
4
2
2
2
1
1
4
2
4
3
2
3
1
1
4
3
4
4
2
4
1
1
4
4
4
5
2
5
3
1
3
2
3
3
3
6
3
2
3
3
3
4
3
7
3
1
3
3
3
2
3
8
3
2
3
4
3
3
3
#DATA_End

structure for a resistance and IP dataset:< br>

1
1
1
1
4
5
4
5

.1115
.1122
.1760
.2114
-.113
-.122
.1175
.1625

12.2
1.5
7.6
4.4
10.1
44.7
16.1
3.3
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| ERTLab | > | 2. Working Environment | > | DATA INPUT | > Topography file format

Topography file format

| << | >> |

ERTLab employs keywords (tags) to indicate subsets of a data file and configuration
information. Currently, the topography file should contain only topography information.
Ultimately this information may be combined into files that also contain quadrapole data
and the mesh configuration. Each keyword starts with the # symbol. The comment
character is !. Any information placed between ! and the end of a file line is ignored.
Blank lines are also ignored.
The Topography format requires an #topo_start keyword to indicate the start of the
topography listing and an #topo_end keyword to indicate the end of the list.
In absence of further tags, the topography is loaded, in the Inversion or Forward modeling
workspace, on the basis of the I/O format parameters specified in the configuration
settings list.
Topography input format can be included in the topography file by using the appropriate
configuration tags. The configuration information may include:
#topo_x_col, column identifier for the X location;
#topo_y_col, column identifier for the Y location;
#topo_z_col, column identifier for the Z location;
The complete list of possible commands is documented in the example below:
#TOPO_X_col=2
#TOPO_Y_col=3
#TOPO_Z_col=4
#TOPO_Start
SurveyControl1
SurveyControl2
SurveyControl3
SurveyControl4
SurveyControl5
SurveyControl6
SurveyControl7
SurveyControl8
SurveyControl9
SurveyControl10
#TOPO_End

100001
100010
100101
100007
100025
100076
100051
100021
100019
100005

1100020
1100001
1100045
1100106
1100092
1100060
1100044
1100036
1100082
1100011

351
357
348
355
352
358
349
350
353
355
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| ERTLab | > | 2. Working Environment | > | DATA INPUT | > Configuration tags

Configuration tags

| << | >> |

ERTLab employs keywords (tags) to indicate configuration information. Each
keyword starts with the # symbol. The comment character is !. Any information placed
between ! and the end of a file line is ignored. Blank lines are also ignored.
The configuration tags can be present both in the schedule-data and in the configuration
files.
The complete list of possible commands is documented in the example below. Descriptions
of the configuration parameters corresponding to the tags and how they affect the models
are found in the Configuration Command Reference .
!Electrodes input/output format
#elec_no_cable= 1
#elec_cable_col= 1
#elec_id_col= 2
#elec_x_col= 3
#elec_y_col= 4
#elec_z_col= 5
#elec_elev_col= -1
#elec_type_col= -1
!Data input/output format
#data_id_col= 1
#data_a_cable_col= 2
#data_a_elec_col= 3
#data_b_cable_col= 4
#data_b_elec_col= 5
#data_m_cable_col= 6
#data_m_elec_col= 7
#data_n_cable_col= 8
#data_n_elec_col= 9
#data_res_col= 10
#data_ip_wind_col= -1
#data_std_res_col= -1
#data_std_ip_col= -1
#data_calc_res_col= -1
#data_calc_ip_col= -1
#data_calc_std_res_col= -1
#data_calc_std_ip_col= -1
#data_appres= 1
#data_ip_scale= 1000.0
!Topography input/output format
#topo_x_col= 1
#topo_y_col= 2
#topo_z_col= 3
!Mesh settings
#mesh_type= 0-Standard
#dim_grid_x= 0.5
#dim_grid_y= 0.5
#dim_grid_z= 0.5
#foreground_x_min= 0.0
#foreground_x_max= 10.0
#foreground_y_min= 0.0
#foreground_y_max= 10.0
#foreground_z_min= -5.0
#foreground_Z_max= 0.0
#pads_x_max= 1 2 4 8 16 24 32 40 48 56 64
#pads_x_min= 1 2 4 8 16 24 32 40 48 56 64
#pads_y_min= 1 2 4 8 16 24 32 40 48 56 64
#pads_y_max= 1 2 4 8 16 24 32 40 48 56 64
#pads_z_min= 1 2 4 8 16 24 32 40 48 56 64
#flat_grid= 1
#use_elec_in_topography= 2
#update_z_surface_electrodes= 2
#adapt_grid_to_electrodes= 2
!Starting model
#resistivity_model_type= 0-Standard
#background_res= 100.0
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#res_anomaly= 0,2 0,2 -3,-1 10
#ip_model_type= 0-Standard
#background_ip= 0.01
#ip_anomaly= 0,2 0,2 -3,-1 0.3
#add_anomalies_to_flat_grid= 2
!Forward solver parameters
#boundary_conds= 1 1 1 1 1
#forw_ssor_omega= 1.6
#forw_tolerance= 1.0E-7
#forw_max_iterations= 400
#skip_tx_electrodes_with_no_rx= 2
#model_ip= 2
!Inversion parameters
#simple_inversion= 1
#max_num_iterations_rho= 15
#max_num_iterations_ip= 15
#max_internal_pcg_rho= 8
#max_internal_pcg_ip= 8
#inv_pcg_tolerance_rho= 0.001
#inv_pcg_tolerance_ip= 0.001
#optimal_rough_factor_rho= 0.9
#optimal_rough_factor_ip= 0.9
#rough_multiplier_rho= 10.0
#rough_multiplier_ip= 10.0
#initial_rough_rho= 10
#initial_rough_ip= 10
#x_rough_weight= 1
#y_rough_weight= 1
#z_rough_weight= 0.1
!Noise
#res_noise_percent= 5
#res_noise_constant= 0.0001
#ip_noise_percent= 5
#ip_noise_constant= 0.00001
#use_robust_inv= 1
#reweight_iterations_rho= 3
#reweight_iterations_ip= 3
!Saving and Plotting parameters
#plot_bounds= 0.0 10.0 0.0 10.0 -5.0 0.0
#save_iterations= 1
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| ERTLab | > | 2. Working Environment | > | DATA INPUT | > Importing IRIS Syscal Bin files

Importing IRIS Syscal Bin files

| << | >> |

After starting a new inversion project the import function will be available on the Explorer
menu. Select Import Syscal file from the Schedule tree.

available.

The import data file workspace appears and the
Quadrapoles button is selected. At the bottom of
the frame the IMPORT SYSCAL BIN menu is
Choose the type of import:
2D
profile
imports
two-dimensional
electrodes
arrangements in a single cable based on X or Y electrode
positions, depending on the 'start numbering' selection.
- 3D grid expects data collected from surface electrodes arranged
as a regular array, in which case a snaking cable is usually
employed.
Ignore these commands if you are going to link the imported
bin file to the original sequence file (see below).
Click the import Syscal file button to open the Windows command
dialog and select the IRIS Syscal bin file with the resistivity and/or
IP data-set to import.

A new window appears and two views are available: the "field Data" view for the
quadrupoles and data and the Electrodes view for the coordinates of the electrodes.

A known issue is that in the Syscal bin format the four electrodes of each quadrupole are
expressed in terms of cartesian coordinates and not using the four numbers that identified
the electrodes during the acquisition. So for three-dimensional arrangements (in particular

17

for "strange" geometries) the electrodes numbering that ERTLab derives can be different
from the one used in the field to acquire the data-set.
This is why a specific command button allows the user to link the bin file to the original
sequence file (ElectreII txt format) used to acquire the measurements. By using this
option (strongly recommanded) the quadrupoles are re-numbered and the coordinates are
attributed to the electrodes in a way consistent with the sequence file.
To import finally the file choose the type of import option in the left part of the Import
Data file window and click the OK button:
- New cable option imports electrodes as a new cable (group of electrodes), attributing a
progressive number.
- Use Cable nr. (..) option permits to import the data-set by using a group of electrodes
(cable) already loaded or to append (if the appropriate checkbox is selected) the current
electrodes to an already loaded cable.
For quadrupole arrays using remote poles, the exact location of the reference electrode
can be specified by the user in the correspondent text box.
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| ERTLab | > | 2. Working Environment | > Viewing electrodes, quadrupoles and data pseudoplots

Viewing electrodes, quadrupoles and data pseudoplots

| << | >> |

Once loaded a schedule file may be viewed for Quality Control and editing by clicking the file
name in the Explorer Window. Three views are available, Quadrapole View for data QC,
Electrodes View for editing of electrode locations and 3D View for a graphic presentation.
These views are further described by following the links.
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| ERTLab | > | 2. Working Environment | > Configuration settings

Configuration settings

| << | >> |

The configuration settings consists of two lists, the smaller Select Items organizer and the
larger view that shows parameters and their values. Use the select Item: list to jump
between logical groupings in the larger parameter list. Each parameter may be modified by
double-clicking in over the value on the right side of the list. The parameters may be
loaded from a file, saved to a file or reset using the buttons in the lower right of this frame.
Descriptions of the parameters and how they affect the models are found in the
Configuration Command Reference. Certain of these commands may be edited graphically
by following links on the Explorer Frame.
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| ERTLab | > | 2. Working Environment | > Making the mesh

Making the mesh

| << | >> |

Choose make mesh from the Explorer window. The make mesh workspace is presented.
Ultimately a series of frames will be available, however you step through these one at a
time, and step backwards through them to change a parameter in an earlier frame. This is
done because the order of choices is critical.

The first frames presented present the option to load topography.
You may choose a flat grid, which will not incorporate the topography, or a grid with
topography in which case the elements will be distorted to accomodate the topographic
surface.
The first way of incorporating topography is loading a file.
Another way to incorporate topographic information is to use the ZTerrain data from the
electrodes. Select Add electrodes Z terrain to topography to use this method.
If topography has been entered but was not available during data collection, then the
electrodes ZTerrain may not be correct. Use Update elevation for Surface-marked electrodes
to fix this problem (note that XY coordinates for the surface electrodes must be in the same
coordinate system as the topographic information).
Finally the switch Adapt grid to electrodes works whether or not topography is present. If
this switch is selected (recommended) then, once a regular mesh has been built the
software will move the closest mesh node to any electrode not already on a node to that
electrode location. If this option is not selected and some electrodes do not fall on nodes
then the electrode locations will be moved, which is less accurate.
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The second frame (right) presents the dimensions of the foreground and background
regions. The foreground dimensions will be automatically chosen from the dataset but
may need to be updated to produce a reasonable sized mesh. This is especially true when
electrode spacings are significantly different in one direction. The spacing chosen
automatically is 0.5 X the smallest electrode spacing (i.e. 2 elements per electrode pair).
Accuracy drops dramatically if fewer than 2 elements are used per electrode spacing.
Working in 3D it is not unlikely that the electrode spacing in one direction (e.g. down the
hole or down the line) is smaller than it is in another direction. For this reason changing the
electrode spacing to be larger in the cross-line and depth (for surface data), or X and Y
directions (for borehole data) should be considered. However, this must be done carefully. It
is recommended that nominal element sizes not be different in one direction by more than a
factor of 2 from any other direction. It is also worth keeping in mind that if the the Adapt
grid to electrodes switch is on, then the finite element mesh will be adapted to electrode
locations. Therefore it is best to use an element size that is half the average down-the-line
electrode separation, rather than half the smallest electrode separation. Sizes and limits are
in meters.
The background region is specified in terms of the nominal foreground element size. The
configuration of these parameters is described here and in the command reference. Each
number present represents the location of a pad node. The number 1 means 1 X the
foreground element size, 2 means 2 X the foreground element size, 4 means 4 X the
foreground element size, etc. The actual pad element size is determined by subtracting the
previous node location. For example if the node list is 1, 2, 4, 8, 16 then the element sizes
are 1, 1, 2, 4, and 8 X the foreground element size. It is recommended that pad cells not
exceed 10 X the foreground element size. The extent of the pad region should be similar to
the size of the foreground region, or larger. For example if there are 40 foreground nodes in
the X direction, then the minimum recommended X background node location is 40. In the Z
direction, for borehole work, the background extent should be 3 X the foreground region. If
the foreground Z contains 20 elements, then the background nodes should extend to 60 X
the foreground element size. For surface data it is probably possible to reduce this ratio.
The basic aspects of mesh design described above are critical to success. Accuracy will be
reduced for any of these reasons:
1) If the number of elements per basic electrode spacing is too small
2) if the number of pad elements is too few
3) if the size of pad elements is too large
4) if the element size in one direction is creater than 2 X the element size in any other
direction.
On the other hand run time will be increased dramatically if the mesh is too large. For each
factor of 2 increase in number of elements, run-time increases by a factor of 8. Therefore it
is very important to spend some time thinking about the mesh design. Typically mesh size
should be kept under 100,000 nodes.

After choosing apply settings the next frame shows the node locations. Use the buttons to
choose between X, Y and Z directions. Nodes may be edited by double-clicking the value.
The add Node box may be used to add a node. The values presented are node locations in
meters. The smallest values are in the -X (Y or Z) background pads. Scroll down the list to
see all the -X background pads. The top of the Foreground node list continues from the
bottom of the -X background pad list. Scroll down the Foreground node list to see the
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extend of the foreground. The top of the +X (Y or Z) background pad list continues from the
bottom of the foreground node list.

Finally the make mesh frame is presented. Check the Nodes and blocks (elements). These
numbers should be reasonable for your computer (typically something between 20,000 and
150,000 is reasonable. Large meshes, especially with a correspondingly large number of
electrodes will take a long time (many hours to days) to compute. Choose View Mesh to
preview the mesh in the 3D viewer to ensure that electrodes and mesh settings are as
anticipated. This step is strongly recommended, especially for large meshes.
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| ERTLab | > | 2. Working Environment | > Resistivity/IP starting models

Resistivity/IP starting models

| << | >> |

Choose make Make Resistivity/IP Model
from the Explorer window. The resistivity
and IP model workspace is presented.
The background resistivity and background
IP values are usually all that are required
for
an
inversion.
Occaisionally
the
inversion needs a better place to start,
and for forward modeling targets must be
placed. For these reasons the resistivity
anomaly
and IP anomaly frame is
presented.
Anomalies are entered as rectilinear
regions using the dimension extents in the
Insert Anomaly area. The extent of the
foreground region is presented for
reference. A resistivity and IP value is
entered for each anomaly, however these
anomalies are maintained separately and
do not have to match. Anomalies are
deleted independantly from the resistivity
and IP areas by pushing the IP and
resistivity buttons. To delete an anomaly,
select it using the mouse, then push
delete anomly. Anomaly shapes other than
rectilinear must be built using a series of
rectilinear anomalies. To make this easier,
each subsequent anomaly overwrites the
previous anomaly in areas of overlap.
When adding anomalies to a topographicaly distorted grid it is usually best to add the
anomalies to the flat grid first. This is done using the checkbox. Otherwise jagged edges
might appear as the software choses a higher elevation element to fill with the anomaly.
Anomalies must completely fill an element, and elements are not distorted to the
accomodate the anomalies, so the ultimate anomaly present in the mesh may not be exactly
the anomaly entered. Please view the mesh prior to modeling to ensure the expected result.
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| ERTLab | > |

3. Survey Design | > Quick overview

Survey Design quick overview

| << | >> |

To enter the forward modeling workspace:

- press the
toobar button
or
- choose File > New Project > Survey Design from the main menu.
Forward modeling is used to test hypotheses and design electrode layouts and array
schedules (quadrapole lists) that best address a specific project. The basic steps for forward
modeling are:
1. Create an electrode layout and generate a sequence
2. Import the electrodes and sequence into the Forward model workspace
3. Design a mesh
4. Create a halfspace model
5. Run the halfspace forward model
6. Create a model with a target embedded in the halfspace
7. Run the target forward model
8. Compare the data values for each quadrapole to determine sensitivity relative to
instrument noise.
9. Revise electrode layout and sequences and repeat steps 1 through 8 until suitable
sensitivity is achieved.
The forward workspace consists of the Configuration settings, data input, Run controls,
Save results, Mesh parameters and Progress info (message area). The explorer screen
provides access to sub-menus that provide graphical input for selected configuration
settings. Run forward solver may be selected at any time after a schedule has been input.
Parameters are automatically chosen by the software. These are overwritten as each
configuration setting is changed either directly on the screen shown, or when following the
menus on the explorer screen. Please follow the links provided for a description of each
sub-menu. To create a schedule for forward modeling, complete with electrode location
information, it may be best to start at with the ERTLab Sequencer.
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| ERTLab | > | 3. Survey Design | > Forward Set up

Forward Setup

| << | >> |

Once loaded a schedule file with the electrodes and quadrupoles, set the appropriate
forward modeling parameters before running the forward modeling.
The forward modeling parameters are set by selecting the item FM set up (or Forward
Solver set up for a Data Inversion session) from the Explorer menu.
A series of 2 tabbed windows is presented. In the main setup we set the Omega. The
default 1.6 is usual. Then the tolerance (smaller numbers result in more computational
effort). We also set the Maximum number of iterations. Larger numbers require more
computational effort. Numbers between 200 and 400 are typical.

In the boundary conditions tab we set the Boundary type for X, Y and negative Z
directions. The positive Z direction is always Neuman (no flow). Neuman may also be used
for certain ungrounded lab experiments, and Direchlet may be used to model grounded
electrodes. Finally the location of the virtual source may be explicitly identified.
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| ERTLab | > | 3. Survey Design | > Forward Modeling

Forward Modeling

| << | >> |

After setting up the forward model, build the resistivity and/or IP model that will be used
to calculate the apparent resistivities/IPs for the loaded quadrupoles.
The model is run by returning to the main FM Workspace (using the Explorer window),
then selecting Run Forward Solver from the menu.

At the end of the forward modelling process, the modelled data set can be viewed in the
data-set 3D view envinroment and saved in data file format by selecting the Save Data
button.
If the modelled data-set has to be processed in an inversion test, it is strongly
recommanded to corrupt synthetic data with random noise, to provide a realistic test of
the inversion.
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| ERTLab | > | 4. Inversion Workspace | > Inversion quick overview

Inversion quick overview

| << | >> |

To enter the inversion workspace press the
toobar button
or
choose File > New Project > Data Inversion from the main menu.
The inversion workspace consists of the Configuration settings, data input, Run controls,
Save results, Mesh parameters and Progress info (message area). The explorer screen
provides access to sub-menus that provide graphical input for selected configuration
settings. Run inversion may be selected at any time after a schedule has been input.
Parameters are automatically chosen by the software. These are overwritten as each
configuration setting is changed either directly on the screen shown, or when following the
menus on the explorer screen. Please follow the links provided for a description of each
sub-menu.
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| ERTLab | > | 4. Inversion Workspace | > Inversion

Inversion

| << | >> |

The inversion parameters are set by selecting Inverse Solver set up from the Explorer
menu.
A series of 3 tabbed windows is presented. In the numerical core we set the Maximum
number of Inverse iterations. A value of 15 is typical for Rho (resistivity) and 10 for IP.
These are sometimes referred to as the outer iterations. We also set the Maximum internal
inverse PCG iterations, which are sometimes called the inner iterations. A value of 12 is
typical for Rho (resistivity) and 20 for IP. Finally we set the Tolerance for the Inverse PCG
iterations. Larger numbers result in faster inversion.

The roughness parameters are the initial roughness factor, the multiplier for changing the
roughness factor and the factor for choosing the optimal roughness factor. Roughness
factor controls that amount of roughness that can be imposed from one iteration to the
next. ERTLab employs roughness trials to determine the optimal roughness factor and the
initial value is of modest importance. If Simple inversion is used then the multiplier for
changing the roughness factor becomes important. If the value is too larger then the
roughness factor will become very small before the inversion is complete.

We also set the Reweight constants in X, Y and Z. Reweight constants less than 1 generate
layering, reweight constants greater than 1 generate smoother models.
The Noise parameters are set on the last tab.
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The inversion is launched by returning to the DI workspace page and selecting Run Data
inversion from the menu. After clicking the Run Inversion button, ERTLab asks to save a
progress file (.prg extension) where the progress of inversion is written.
Diagrams describing the behaviour of the inversion are automatically displayed in the
inversion progress graphics window that appears after saving the progress file.
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| ERTLab | > | 4. Inversion Workspace | > Save results

Save results

| << | >> |

After running a model the results must be saved. This
does not happen automatically. The resistivity (Rho)
and IP models are saved separately. The saved model
contains electrodes, mesh nodes, data values for each
element and quadrapoles. It may be viewed using the
ERTLab 3DViewer. If Save XYZ is selected then a
separate file with data values posted at the element
centers and columns X,Y,Z, Data is saved. Note that
only the
region indicated by the parameter Plot
Bounds is saved. To save the entire model including
the background region choose "Export Mesh and
Resistivity model" from the Explorer Frame The Save
Schedule button saves only the Quadrapoles and data. The mesh is not saved.
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32

| ERTLab | > | 5. Schedule workspace | > Electrodes tab

Electrodes tab

| << | >> |

When the dataset is selected from the Schedule window in the explorer, or from one of the
menus in the Data Quality Control area, three workspaces become available. They are
accessed by the buttons at the top of the screen called Quadrapoles, Electrodes and 3D
View.
On the electrodes and Quadrapoles screens
three menus appear at the bottom of the
workspace. These are IMPORT SYSCAL BIN,
REMOVE BAD DATAPOINTS and SAVE SCHEDULE. The import syscal menu is only active if
you go directly to this screen from the explorer. Rather than using Input schedule under
DATA INPUT of the DI Workspace click Import Syscal File under The schedule menu on the
Explorer. The remove bad datapoints is for editing data values and is best described in the
quadrapoles description.
On the electrodes screen a listing of electrodes with their locations is presented.

The cable column is the number of the logical group (cable, well, line). The ID is the
electrode number within the group. x(m), y(m) and z(m) are the electrode location in
meters. ZTerrain is the surface elevation above the electrode (usually equal to z(m) for
surface electrodes. Type is Surface or Borehole. Remote signifies whether the electrode is
located in the foreground or background region of the mesh.
Editing of the coordinates
- Any value except Cable and ID may be changed by double clicking directly over the value
on the list.
- X, Y and Z coordinates can be changed for two or more elecrodes by selecting the
electrodes and right clicking the selected cells.
- For electrodes belonging to a 2D profile it's possible to interpolate the Z Terrain elevation
between two electrodes by selecting the correspondent cells of the ZTerrain column and
right clicking the selected cells.
The Electrode type setting (borehole or surface) results in different behavior during mesh
generation and sequence generation. For example topographic surfaces may be extract from
surface electrodes.
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| ERTLab | > | 5. Schedule workspace | > Quadrapoles

Quadrapoles tab

| << | >> |

When the dataset is selected from the Schedule window in the explorer, or from one of the
menus in the Data Quality Control area, three workspaces become available. They are
accessed by the buttons at the top of the screen called Quadrapoles, Electrodes and 3D
View.
On the electrodes and Quadrapoles screens
three menus appear at the bottom of the
workspace. These are IMPORT SYSCAL BIN,
REMOVE BAD DATAPOINTS and SAVE SCHEDULE. The import syscal menu is only active if
you go directly to this screen from the explorer. Rather than using Input schedule under
DATA INPUT of the DI Workspace click Import Syscal File under The schedule menu on the
Explorer. The remove bad datapoints is for editing data values and is best described in the
quadrapoles description.

When a schedule file containing data has been input, either from the data inversion (DI)
workspace or the syscal import, the quadrapole list is populated. The following columns are
visible: ID is simply a count for the data in the list. cA, cB, cM and cN are the cable ID's for
the ABMN (quadrapole) electrodes and A, B, M, N are the electrode numbers of the ABMN
electrodes. V/I in Ohms is the measured resistance. V/I Rec. (ohm) is the corresponding
reciprocal data point (these must be determined as described below). V (in millivolts) is the
measured primary voltage. Scrolling to the right other columns are visible depending on
exact data measured and calculated. These columns are common:

I (in milliamperes) is the current flow, K is the geometric factor (a multiplier used to
calculate apparent resistivity). Rho is the calculated apparent resistivity, q is a quality
control factor such as standard deviation, from the measured data (not always present), IP
is the induced polarization (not always present) and skip is a QC column. If the skip column
shows a 1 then the datapoint will be skipped during inversion. This flag may be set manually
be double-clicking the value on the list, or automatically using the REMOVE BAD
DATAPOINTS menu.

The REMOVE BAD DATAPOINTS menu allows removal (skipping) of datapoints based on
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various parameters. First select the parameter, then click Remove Data. Using the Elect.
buttons you can remove based on cable ID or electrode ID. Using the Meas. buttons you can
remove based on thresholds for values such as V (measured primary voltage), abs(V) the
absolute value of measured primary, I (current flow), abs(I), V/I (measured resistance),
abs(V/I), K (geometric factor), abs(K), Rho (apparent resistivity), abs(Rho), IP (measured
induced polarization, abs(IP), q (measured quality control indicator, abs Rec. Diff (absolute
reciprocal difference), % Rec Diff (Percent reciprocal difference). You can also choose to skip
any data that do not have a corresponding reciprocal by selecting "Remove no-reciprocals
data". Finally you can choose to "Remove duplicated data points".
Each filter that is applied simly adds to the skip list. Data are not removed from the skip list
except by using the Skip reset button. The final filtered dataset can be saved using the Save
Schedule button.
The include IP data switch saves IP data as an extra data column. The
Save Terrain info switch saves the ZTerrain information with the
electrodes.
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| ERTLab | > | 5. Schedule workspace | > 3DView

3DView

| << | >> |

When the dataset is selected from the Schedule window in the explorer, or from one of the
menus in the Data Quality Control area, three workspaces become available. They are
accessed by the buttons at the top of the screen called Quadrapoles, Electrodes and 3D
View.
On the electrodes and Quadrapoles screens
three menus appear at the bottom of the
workspace. These are IMPORT SYSCAL
BIN, REMOVE BAD DATAPOINTS and SAVE SCHEDULE. The import syscal menu is only
active if you go directly to this screen from the explorer. Rather than using Input schedule
under DATA INPUT of the DI Workspace click Import Syscal File under The schedule menu
on the Explorer. The remove bad datapoints is for editing data values and is best described
in the quadrapoles description.
The 3D View button presents a workspace that graphically shows the electrode locations
and color coded apparent resistivity plotted at an appropriate location with respect to the
quadrapole used to collect the datapoint.

Graphical controls using the mouse are as follows: Left click hold and move rotates the view
area. Ctrl (Control) left click and move pans the view. Shift Right-click hold and move
zooms the view area. Double click of any apparent resistivity colored dot sets the datapoint
skip value to 1, i.e. datapoints selected this way will not be used in the inversion. If you
hover over any apparent resistivity plotted point you get information about that point. If
you hover over an electrode the location of that electrode is displayed.
Two menus are available:
Rather than using the mouse
controls as indicated above the
View aspect may be changed by
directly entering values in the
thera, gamma (rotate), thi, and
zeta (zoom) controls.
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The OW button presents a non-perspective view, the PW button imposes perspective. The
XY, ZY and ZX buttons snap to the planes indicated. The Elec. switch switchs off the
electrodes, the Quad switch switches off the apparent resistivity presentation, the box
switch turns on an outline box, the label switch turns on XYZ coordinate labels for the
extents of the box. The cls switch turns on a color bar and the extents of the color bar may
be modified using the text entry boxes to the right of the cls switch. The coloring of the
data presentation will change as the color bar extents are changed.
On the left menu, a list of quadrapoles may be
displayed by checking the Quad. List box.
When quadrapoles are selected from the list
the ABMN electrodes are numbered using the
electrode number in the view area.
If one of the X, Y or Z buttons is pushed then a subset of the data from a plane is
displayed. The elevation of the plane is controled used the slider bar or text entry.
On the screen shown the select button is actually labeled display. Display must be pushed
to calculate the apparent resistivities for display.
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| ERTLab | > | 5. Schedule workspace | > Reciprocal check

Reciprocal check

| << | >> |

If reciprocals were acquired, ERTLab gives the possibility of implementing statistical checks
to control the quality of the measured data-set. The reciprocal check tasks are accessed
through the Table of Reciprocals menu of the explorer window.
Select the Reciprocal Check button of this workspace to perform Resistance/IP reciprocal
checks. ERTLab calculates absolute differences, percentual differences and few statistics that
can be useful to understand the field noise values. Reciprocal data points are written to the
quadrapole tab of the Schedule workspace. Duplicates are calculated too.
The table of reciprocals can be sorted in different ways and a text file of reciprocals can be
exported by selecting the Save Table command.
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38

| ERTLab | > Glossary

Glossary of Terminology used in ERTLab

| << | >> |

ERTLab employs the following termininology for aspects of ERT, XIP, computer systems
and data:
3D
Three dimensional or three dimensions. This is a reference to maps of volume or space
that use 3 orthogonal cartesian coordinates (XYZ) to identify a point location.
2D
Two dimensional or two dimensions. This is a reference to maps of volume or space that
use 2 orthogonal cartesian coordinates (typically X and Z) to identify a point location. A
single straight line of data collected at surface is usually considered to be a two
dimensional dataset because the target area is directly below the survey line.
Absolute Roughness
See Roughness.
ABMN
Common four electrode (quadrapole) array designation. A and B are the transmitter
electrodes, M and N are the receiver electrodes.
Apparent Resistivity
Resistivity of a halfspace the corresponds to an individual quadrapole configuration.
Blocks
Used interchangeably with elements.
Background Region
The portion of the mesh outside the main area of interest. The background region is used
when simulating (modeling) a real earth to extend the mesh in +/- X, +/- Y and -Z
directions to create a pseudo-infinite halfspace for mitigation of boundary effects.
Boundary Conditions
The first and last elements of a mesh may terminate in a variety of electrically reasonable
ways. The most obvious is no-electrical current flow outside the boundary, but
zero-voltage (grounded) is also reasonable, and mixed conditions are often implmented.
Cable
Any logical grouping of electrodes (e.g. one multiconductor cable with takeouts or one
instrumented borehole may be identified as a single cable).
Chargeability
Induced polarization measured in the time domain, a physical property often thought of
interms of capacitance or the ability of the earth to store a charge. Units are expressed as
off-time voltage times a factor of 1000, divided by on-time voltage (mV/V). The
measurement of chargeability is complex and no clear standard is available, especially
when waveforms other than the .125 Hz rectangular wave (2 seconds on / 2 seconds off)
are used. Usually the off-time voltage is measured as a series of 'windows' values
collected a different delays after turn-off but before the transmitter turns on again. These
windows are most commonly averaged so that an equivalent value for the approximate
middle of the turn-off period is presented.
Convergence
A measure of model fit. When the the model has fit the data we say it has converged. The
term is used because at each iteration the model comes closer and closer to (converges)
on a reasonable fit. We compare the total number of ERT data to the data error (misfit or
residual) as a means of determining whether the model has converged. This is commonly
called the

?2error.

Data Residual
The root of the sum of the squares of the difference between input data and modeled
data.
Dipole
A pair of electrodes. The name is not typically applied unless the electrode pair is used as
either a transmitter or receiver.
Electrode
Any electrical connection to the earth. This may be accomplished using stainless steel,
grounding rod, graphite (usually used in marine environments), lead, silver-silver chloride
(usually used in lab experiments), titanium, etc.
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Element
A 3D tetrahedral space that is assigned a unique resistivity or IP value.
EIT
Electrical Impedance Tomography. The practice of collecting resistivity data and inverting
them to produce a tomographic or 3D image.
ERT
Electrical Resistivity Tomography. The practice of collecting resistivity data and inverting
them to produce a tomographic or 3D image.
Foreground Region
The portion of the mesh that encompases the main area of interest.
Forward modeling
Forward modeling is the process of creating a data suite (schedule) from a 3D resistivity
dispersion (in a 3D mesh).
Flag
Programmers terminology for a record (data field) that contains a number or string (a
word) that provides the answer to a question that typically has a small set of answers,
usually Yes / No, or True/False. For example we implement a skip flag of 0 to indicate the
datapoint should be skipped and a 1 to indicate it should be used.
Flat Grid
Modeling mesh created without topography (i.e. the top or +Z direction is flat).
Halfspace
A semi-infinite region divided in two with half the volume assigned a constant finite
resistivity and half the volume assigned a constant infinite resistivity.
Inversion
Inversion is the process of creating a resistivity dispersion (in a 3D mesh) that matches
the data available.
IP
Induced polarization, a physical property often thought of interms of capacitance or the
ability of the earth to store a charge. Units are chargeability, expressed as off-time
voltage times a factor of 1000, divided by on-time voltage (mV/V).
Iteration
Cycle. During the inversion process a resistivity model is generated, the data errors are
calculated and a new resistivity model is generated. Therefore at the end of each iteration
a resistivity model is available.
Mesh
The mesh is a 3D array of elements.
Model
Combination of a mesh whose elements have been assigned a resistivity and / or IP value
with a listing of electrodes and thier locations and a schedule of quadrapoles based on
these electrodes with measured and / or synthetic data for each quadrapole.
Model Fit
The degree to which the resistivitydistribution in the model is capable of generating the
observed data.
Node
A verticy of a mesh element.
Pad (Pads or Padding element)
A mesh element that is a member of the mesh background region.
Quadrapole
A four electrode array or distribution of electrodes. The first two electrodes identify the
positive and negative transmitter (AB); and the second two electrodes identify the positive
and negative receiver (MN). In ERTLab we express a quadrapole in terms of electrode ID
following the Lawrence Livermore Cable Electrode format (both a cable ID and an
electrode ID are required to identify an individual electrode).
Receiver
A dipole or pair of electrodes use to receive voltage.
Reciprocals
The theory of reciprocity states that for electrical data transmitters and receivers should
be interchangable. That is, the same data should be collected whether dipole A is used as
transmitter and dipole B as a receiver or dipole B as transmitter and dipole A as receiver.
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In practice this generally holds true unless one of the dipoles is much larger than the
other (i.e. a remote electrode is used).
Remote Electrodes
Electrodes used only as reference (zero or ground) which are usually placed outside the
foreground region. These may be employed, for example, by certain named quadrapole
arrays such as pole-dipole, gradient, and pole-pole.
Resistivity
Electrical resistance X a unit of length. Expressed in Ohm-m.
Resistance
Electrical resistance from Ohm's law (R=V/I) where V is voltage and I is current.
Expressed in Ohm.
Reweight Ratio
A measure of the amount of data that has effectively been ignored by the model. This
parameter only applies if Robust inversion is being used. Numbers larger than 5 indicate a
significant portion of the data has been ignored.
Roughness
A measure of the heterogeneity in model. Larger numbers represent more heterogeneity.
Also called Absolute Roughness.
Roughness Parameter
This controls the ability of the inversion to make large changes to the model
heterogeneity. The larger the number, the greater the changes allowed. Also called the
roughness factor.
Schedule
A listing of quadrapoles. Data may or may not follow each quadrapole listing depending on
the intended use or stage.
Transmitter
A dipole or pair of electrodes to which a voltage is applied.
XIP
Cross-hole IP. The practice of collecting IP data in boreholes and inverting them to
produce a tomographic or 3D image.
ZTerrain
Data used in the electrode definition to specify the elevation of surface above an
electrode.
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| ERTLab | > Command Reference for ERTLab

Command Reference for ERTLab

| << | >> |

ERTLab employs the following commands. These may be entered directly in the
configuration settings displayed in both the inversion and forward workspaces, through an
input file, or by using the menu system.

Mesh settings
Type of mesh
Only mesh type 0 is available.
Interior Grid Element X Size (m)
Nominal X element size. If the mesh is adapted to electrode positions then this will vary
modestly.
Interior Grid Element Y Size (m)
Nominal Y element size. If the mesh is adapted to electrode positions then this will vary
modestly.
Interior Grid Element Z Size (m)
Nominal Z element size. If the mesh is adapted to electrode positions then this will vary
modestly.
Mesh Minimum X Distance (m)
Nominal Z element size. If the mesh is adapted to electrode positions then this will vary
modestly.
Mesh Maximum X Distance (m)
Nominal largest extent of the mesh in the X direction (value in meters).
Mesh Minimum Y Distance (m)
Nominal smallest extent of the mesh in the Y direction (value in meters).
Mesh Maximum Y Distance (m)
Nominal largest extent of the mesh in the Y direction (value in meters).
Minimum Z Value (m)
Nominal smallest extent of the mesh in the Z direction (value in meters).
Maximum Z Value (m)
Nominal largest extent of the mesh in the Z direction (value in meters).
Grid Right (+X) Pads (interior X grid units)
Pad elements that define the background region of the mesh in the positive X direction.
For each number given, a single pad element is appended starting at the specified edge of
the foreground region. Each subsequent number represents the ultimate size of the
background region in this direction in terms of the equivalent number of interior mesh
elements for that direction. The size of any single pad element is determined by
subtracting the given value from the previous value and multiplying by the interior grid
element size for the given direction. Default values are: 1 2 4 8 16 24 32 40 48 56 64;
which specifies 11 pad elements whose sizes in meters are 1, 1, 2, 4, 8, 8, 8, 8, 8, 8 and
8 times the interior grid element size.
Grid Left (-X) Pads (interior X grid units)
Pad elements that define the background region of the mesh in the negative X direction.
For each number given, a single pad element is appended starting at the specified edge of
the foreground region. Each subsequent number represents the ultimate size of the
background region in this direction in terms of the equivalent number of interior mesh
elements for that direction. The size of any single pad element is determined by
subtracting the given value from the previous value and multiplying by the interior grid
element size for the given direction. Default values are: 1 2 4 8 16 24 32 40 48 56 64;
which specifies 11 pad elements whose sizes in meters are 1, 1, 2, 4, 8, 8, 8, 8, 8, 8 and
8 times the interior grid element size.
Grid Back (-Y) Pads (interior Y grid units)
Pad elements that define the background region of the mesh in the positive Y direction.
For each number given, a single pad element is appended starting at the specified edge of
the foreground region. Each subsequent number represents the ultimate size of the
background region in this direction in terms of the equivalent number of interior mesh
elements for that direction. The size of any single pad element is determined by
subtracting the given value from the previous value and multiplying by the interior grid
element size for the given direction. Default values are: 1 2 4 8 16 24 32 40 48 56 64;
which specifies 11 pad elements whose sizes in meters are 1, 1, 2, 4, 8, 8, 8, 8, 8, 8 and
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8 times the interior grid element size.
Grid Front (+Y) Pads (interior Y grid units)
Pad elements that define the background region of the mesh in the negative Y direction.
For each number given, a single pad element is appended starting at the specified edge of
the foreground region. Each subsequent number represents the ultimate size of the
background region in this direction in terms of the equivalent number of interior mesh
elements for that direction. The size of any single pad element is determined by
subtracting the given value from the previous value and multiplying by the interior grid
element size for the given direction. Default values are: 1 2 4 8 16 24 32 40 48 56 64;
which specifies 11 pad elements whose sizes in meters are 1, 1, 2, 4, 8, 8, 8, 8, 8, 8 and
8 times the interior grid element size.
Bottom (-Z) Pads (interior Z grid units)
Pad elements that define the background region of the mesh in the negative Z direction.
For each number given, a single pad element is appended starting at the specified edge of
the foreground region. Each subsequent number represents the ultimate size of the
background region in this direction in terms of the equivalent number of interior mesh
elements for that direction. The size of any single pad element is determined by
subtracting the given value from the previous value and multiplying by the interior grid
element size for the given direction. Default values are: 1 2 4 8 16 24 32 40 48 56 64;
which specifies 11 pad elements whose sizes in meters are 1, 1, 2, 4, 8, 8, 8, 8, 8, 8 and
8 times the interior grid element size. Note that pad elements are not required in the
positive Z direction because the boundary is always Neuman, i.e. no current flow.
Flat grid -1; Grid with topography -2
Use 1 for a mesh without topographic distortion, 2 to automatically adapt the surface (+Z)
to the topographic relief specified either in the electrode ZTerrain or using a separate
topography file.
Add electrodes Z terrain to topography: Yes-1; No-2
Use 1 to add the ZTerrain information from the electrode definition to the list of
topographic points.
Update elevation for Surface electrodes: Yes-1; No-2
Use 1 to move Z coordinate of the surface electrodes to the topographic surface that was
specified by importing a topography file. (Note that X and Y coordinates of the electrodes
must be in the same coordinate system as the topography file).
Adapt grid to electrodes: Yes-1; No-2
Use 1 to snap (move) the nearest mesh node to the electrode location. Electrodes must
fall on mesh nodes. If 2 is used then any electrodes that do not fall on nodes will be
moved to the nearest node. Adapting the mesh is generally more accurate than moving
the electrodes.

Starting model
Type of resistivity model
Only model type 0 is available.
Background Resistivity (ohm m)
The value entered here will be assigned to each element of the starting mesh, except
when anomalies are supplied then those values will overwrite the background value
supplied here.
Number of Resistivity Anomalies
The number of resistivity anomalies that will be employed in the starting model.
Anomalies are used for forward modeling, and occaisionally to provide a more accurate
starting guess for inversion.
Res. Anomalies: -X,+X -Y,+Y -Z,+Z Resistivity
The location of a rectilinear resistivity anomaly. Seven values are expected, the negative
and positive X extents (in meters), the negative and positive Y extents (in meters), the
negative and positive Z extents (in meters) and the resistivity of the block (in ohm-m).
More than one anomaly may be specified. Each subsequently specified anomaly overwrites
the previous one if overlap occurs. Shapes other than rectilinear must be built using a
series of these rectilinear anomalies.
Type of IP model
Only model type 0 is available.
Background Ip Value
The value entered here will be assigned to each element of the starting mesh, except
when anomalies are supplied then those values will overwrite the background value
supplied here.
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Number of IP Anomalies
The number of IP anomalies that will be employed in the starting model. Anomalies are
used for forward modeling, and occaisionally to provide a more accurate starting guess for
inversion.
IP Anomalies: -X,+X -Y,+Y -Z,+Z IP
The location of a rectilinear IP anomaly. Seven values are expected, the negative and
positive X extents (in meters), the negative and positive Y extents (in meters), the
negative and positive Z extents (in meters) and the IP of the block (in chargeability). More
than one anomaly may be specified. Each subsequently specified anomaly overwrites the
previous one if overlap occurs. Shapes other than rectilinear must be built using a series
of these rectilinear anomalies.
IP Scale Factor (1000 for Chargebility)
A scale factor may be applied to IP data to convert from alternative units.
Add anomalies to flat grid: Yes-1; No-2
A value of 1 will add any anomalies (both resistivity and IP) to a flat, pre-topographic
distortion mesh. Adaptations to a topographic surface (if used) are distributed throughout
the mesh to minimize element distortion. Since any anomalies applied must completely fill
the elements they affect, the rectilinearly defined anomalies will necessarily be distorted in
the final mesh. This distortion is minimized if the anomalies are applied to the flat grid
before the mesh is adapted to topography.

Forward solver parameters
[-/+X;-/+Y;-Z] Boundaries (0-Dir, 1-Mixed, 2-Neu)
Used to set the type of boundary conditions for each face of the model (edge of the mesh)
except plus Z. The plus Z direction is the earth’s surface and is always 2 (Neuman or
no-flow). –X and –Y indicate the first elements of the mesh in the X and Y directions, +X
and +Y indicate the last mesh elements in the X and Y directions. Defaults are mixed (1)
everywhere. Dirichlet or zero voltage boundaries (0) may be used to represent a
grounded electrode; and Neuman or non-flow boundaries (2) may be used to represent
an electrically isolated area such as a water tank or similar laboratory studies.
Omega: Used for SSOR precond
This parameter is used to adjust the convergence rate of the forward model. It controls
the error reduction factor. Allowable values are 1.0 to 2.0.
Forward Solver Tolerance
This parameter indicates the stop criteria for the forward model. The smaller the value the
more accurate the forward model, but longer processing time is required.
Maximum Number Forward Iterations
Indicates the maximum number of iterations for the forward model that will be performed.
The larger the number the slower the solution.
Skip TX electrodes with no RX-1; Calc. All -2
A value of 1 will skip calculations for electrodes used only as transmitters. This may be
useful to speed calcuation times when remote electrodes, which are typically only used as
transmitters, are employed.
Model IP Data: No-1; Yes-2
A value of 2 will cause IP data to be modeled (either forward or inverse). This is
performed after resistivity data are modeled.

Inversion parameters
Simple Inversion: Yes-1; No-2
ERTLab inversion strategy employs trials to determine the optimal roughness parameter
that should be used for each outer iteration. Since this strategy results in significantly
longer calculation times for each outer iteration for which it is employed, the Simple
Inversion switch allows the user to turn the trials off for all but the first outer iteration. If
simple inversion is used then the roughness parameter used for subsequent outer
iterations is the previous roughness parameter divided by the user controlled multiplier.
Maximum Number Inversion Iterations-Rho
This is the maximum number of outer iterations the user will allow the program to
perform during inversion of resistivity data. Fifteen is usually a good starting point. The
code will usually converge in fewer iterations.
Maximum Number Inversion Iterations-IP
This is the maximum number of outer iterations the user will allow the program to
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perform during inversion of IP data. Resistivity inversion happens before IP inversion.
They do not happen concurrently. Ten is usually a good starting point. The code will
usually converge in fewer iterations.
Maximum Internal Inverse PCG Iterations-Rho
This is the maximum number of inner iterations the user will allow the program to perform
during inversion of resistivity data. Twelve is usually a good starting point.
Maximum Internal Inverse PCG Iterations-IP
This is the maximum number of inner iterations the user will allow the program to perform
during inversion of IP data. Twenty is usually a good starting point.
Tolerance for Inverse PCG iterations-Rho
This parameter indicates the stop criteria for the resistivity inversion. Bigger
result in earlier stopping. Allowable values are .1 to .001.
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Tolerance for Inverse PCG iterations-IP
This parameter indicates the stop criteria for the IP inversion. Bigger numbers result in
earlier stopping. Allowable values are .1 to .001.
Factor <1 for choosing optimal Roughness Factor-Rho
This factor controls the identification of the optimal roughness parameter.
Factor <1 for choosing optimal Roughness Factor-IP
This factor controls the identification of the optimal roughness parameter.
Multiplier for Changing Roughness Factor-Rho
This factor controls the degree of change between roughness parameters when stepping
to the next outer iteration during simple inversion.
Multiplier for Changing Roughness Factor-IP
This factor controls the degree of change between roughness parameters when stepping
to the next outer iteration during simple inversion.
Initial Roughness Factor-Rho
This is the initial roughness parameter for the first outer iteration trial.
Initial Roughness Factor-IP
This is the initial roughness parameter for the first outer iteration trial.
Constant Value for Param X Weights
Used to control layering, factors smaller than 1 will increase layering in the X direction.
Factors greater than 1 will increase smoothness.
Constant Value for Param Y Weights
Used to control layering, factors smaller than 1 will increase layering in the Y direction.
Factors greater than 1 will increase smoothness.
Constant Value for Param Z Weights
Used to control layering, factors smaller than 1 will increase layering in the Z direction.
Factors greater than 1 will increase smoothness. The default is to impose layering in the Z
direction.

Noise
Rho Data Percent Errors (%)
This parameter controls the acceptable percent difference between the data and the model
(the inversion will converge to this error level). The value entered here should reflect the
estimated degree of data repeatability (i.e. the actual noise in the field data), which is
easily obtained if reciprocal data were collected. This term works in conjunction with the
constant error term to determine convergence.
Rho Data Constant Error Term
This parameter indicates the acceptable absolute difference between the data and the
model that is acceptable (the inversion will converge to this error level). The value
entered here should reflect the estimated lower noise threshold of the instrument used to
collect the data. This term works in conjunction with the percent error term to determine
convergence.
IP Data Percent Errors (%)
This parameter controls the acceptable percent difference between the data and the model
(the inversion will converge to this error level). The value entered here should reflect the
estimated degree of data repeatability (i.e. the actual noise in the field data), which is
easily obtained if reciprocal data were collected. This term works in conjunction with the
constant error term to determine convergence.
IP Data Constant Error Term
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This parameter indicates the acceptable absolute difference between the data and the
model that is acceptable (the inversion will converge to this error level). The value
entered here should reflect the estimated lower noise threshold of the instrument used to
collect the data. This term works in conjunction with the percent error term to determine
convergence.
Use robust inversion (data errors reweight)-1; No -2
A value of 1 sets use of robust inversion. This strategy allows the code to ignore data
outliers (those data with the worst model fit) so they are no longer important to the
solution. Except in the most rigorously controlled field situations this strategy should be
used. When inverting synthetic or forward data this option should be turned off. Even
when robust is used it is possible that the inversion will not converge. This may happen
when all of the data have approximately the same deviations and no outliers can be
identified.
Number of reweight iterations-Rho
This parameter controls the number of trials that may be attempted when searching for an
optimal roughness parameter.
Number of reweight iterations-IP
This parameter controls the number of trials that may be attempted when searching for an
optimal roughness parameter.

Saving and Plotting parameters
Plot bounds: -X +X -Y +Y -Z +Z
These parameters control the extents of the output model. Typically only the foreground
region is output. However for thin models (e.g. 2D models), the extents output should be
widened. The units are in meters.
Save inverted model for each iteration: Yes-1; No-2
A value of 1 causes a model to be output (written to disk) after each outer iteration.
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Introduction
This tutorial is designed to lead you through the steps to build a simple forward model. Forward modeling is useful to determine system
response and target detectability. Knowledge of these parameters is valuable for survey design that involves two key decisions, where to
place the electrodes and what arrays to use. The location of electrodes is primarily based on signal strength vs cost and a knowledge of
instrument and site parameters such as output current, noise and target type and size are necessary. The choice of arrays depends on such
parameters as distance of target from nearest electrodes, time available to collect readings and availability of sophisiticated interpretation
tools such as ERTLab inversion algorithms. For complex systems and sites forward modeling is not only important, it is necessary. This
tutorial addresses a relatively simple situation and is designed to provide a solid foundation in the practice.

Getting Ready
The first step is to gather knowledge of the host and target and determine what types of electrode installation will be permitted. Parameters
to consider for the host are bulk resistivity, geological layering, extraordinary features such as extremely resistive or conductive layers and
site conditions that may require special (i.e. costly) electrode installation methods. For the target, consider the nature of target, size, form
and resistivity. For the electrode installation consider the goals of the survey (characterization vs monitoring), the type of system that will be
used (multi-channel, multi-electrode), the number of electrodes that may be hooked to the system at once, and the environmental conditions
at surface and depth (activity at the site, power-lines, surface paved or grass, underground utilities).

Target Configuration
In this simple case we will assume a clean host environment, a homogenous (non-layered) halfspace host, a simple rectalinear three
dimensional target, willingness to install boreholes for electrode installation and multi-electrode ERT system. The target will be 2 X 4 X 5 m
relative conductor in a typical vadose zone host with a 4:1 constrast. We will use 200 ohm-m resistivity for the host and 50 ohm-m for the
target with an intrinsic IP of 100 mV/V. We will arrange 4 boreholes with 15 electrodes (requiring a 60 electrode multiplexed system) in a
square around the target, with the target located closer to one of the boreholes (offset from the center of the boreholes. The electrode strings
will be arranged ideally, maintaining a 2:1 aspect ratio and extending 50% below the maximum target depth.

Overview of steps
The following steps will be followed:
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.

Configure the borehole arrangement using the ERTLab Sequencer.
Schedule a sequence in the ERTLab Sequencer.
Configure the host and target in the ERTLab Solver.
View the configuration with the ERTLab Viewer.
Prepare and run the forward model without the target.
Prepare and run the forward model with the target.
Compare the models in Excel or other Spreadsheet.
View the model with target using the viewer.
Invert the forward model with the target.
View the inversion with the ERTLab Viewer.

Step 1: Configure the borehole arrangement using the ERTLab Sequencer
1. Start the ERTLab solver environment by selecting it from the start menu.
2. Start the ERTLab Sequencer by selecting
- Tools>ERTLab Sequencer

- or clicking the

button.

- or by starting the ERTLab Sequencer directly from the Start menu.
3. The ERTLab Sequencer starts at the cable entry screen.
4. Change the electrode count to 15. Notice a yellow prompt appears requesting enter to update. Press enter.
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- notice the X cable end changes to 14 m.
5. Locate the borehole checkbox and click it so that it is checked (notice the cable end is now adjusted in Z rather than X and is negative).
6. Since we will locate the first borehole at 0,0 X and Y coordinates leave these and push the Insert button. A grid and dot representing
the bottom electrode will appear in the 3D View area.
7. To orient the 3D View
Press the ortho button in the move area.
Click in the upper, mid-right of the 3DView and drag the mouse to the lower, mid-left.
Hold the Ctrl button and click in the upper, mid-left area, pan the view to the center, mid-left and release.

8. To insert another cable:
Enter 7 in the Y cable start and push enter
Enter 7 in the Y cable end and push enter.
Push the insert button.
Another cable appears on the screen.
9. Another way to insert a cable is to move it after insert.
Push insert again. Notice that while nothing appears to have changed in the image, the cable count is now 3. This is because the
new cable was inserted directly on top of the last cable.
Move the new cable 7 meters in X by pushing the
right X button in the Move Cable frame.
10. Yet another way to insert a cable is to adjust it after insert.
Push insert. A new cable is inserted on top of the last one.
Change the Y start to 0 and push enter
Change the Y end to 0 and push enter
Push Update Cbl.
The new cable moves to the coordinates indicated.
11. Any cable may be adjusted by selecting it.
to select any cable double click on any of the cables electrodes.
Adjust the cable using any of the methods above.
12. To recenter the view, click the Grd. Auto check box at the bottom center of the screen so it is checked.
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Step 2: Schedule a sequence in the ERTLab Sequencer.
Before a file can be saved in ERTLab format at least one sequence must be built. Follow these steps to build a simple reciprocating
dipole-dipole sequece.
1. Select Sequence > Make-Multi-borehole sequence from the menu.

2. Push the Dip-Dip button on the Multi-borehole array menu.
3. Notice both common-cable and cross-cable choices are selected. Common cable confines the transmitter and receiver to a single cable.
Cross cable forces the transmitter and receiver to be on opposite cables.
4. Notice the V mode is chosen for both Tx and Rx. V means the dipole is oriented vertically. H means it is oriented horizontally.
5. Notice the a List dipole length. Dipole length is specified in terms of electrode spacing on the cables. Multiple 'a' spacings may be
generated at once, and the default is 1,2 and 3 electrode spacings. To keep things simple for now, change this to read '1' only.
6. Notice in Tx, Rx distance there is a list of 'n' spacings that will be generated and this is filled to n=12. An alternative syntax is
available. This is startingN:step:endingN, so for the list shown the syntax would be 1:1:12. In order to ensure that we get all possible
'n' spacings change the list shown to read 1:1:50.
7. Push the

make sequence button. A message will pop up indicating the number of quadrapoles generated.
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8. To view the quadrapoles select Sequence>View Quadrapole List from the sequence menu, or push the F11 keyboard button.
9. Click any quadrapole in the list and the transmitter electrodes will be shown in red, the receiver electrodes in green.
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10. Multiple sequeces may be generated, or the sequences generated may be erased by returning to the Make Multi-borehole sequences
menu.
11. The tools menu provides tools such as removal of duplicates, addition and removal of reciprocals and optimization for multi-channel ERT
instruments.
12. To save the sequence choose File>Save>ERTLab Format from the file menu.
1. Use a file name like ForwardSequence1.schd (the extension is added automatically).
13. Close out of the ERTLab Sequencer using File>Quit on the File menu or by pushing the X in the upper right corner of the window.
Setp 3: Configure the host and target in the ERTLab Solver.
You are now ready to configure the host and target.

Step 3:Configure the host and target in the ERTLab Solver.
1. Return to, or start the ERTLab Solver environment.
2. From the choose File>New Project > Survey Design from the file menu or push the
survey design button.
3. Under Data input click on input Schedule. Find the file generated above (ForwardSequence1.schd) and open it.
4. The screen and configuration settings will be updated as shown.
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5. Scroll through the configuration settings using the scroll bar on the right of the list. Note that you can jump to grouped items using the
Select item menu to the left of the list.
Click on Mesh settings under the Select Item, or scroll to Mesh settings.
Notice that Interior Grid Element X size (m) is .5 m and Interior grid element sizes for Y and Z are also .5 m. These are set
automatically and are based on the electrode spacing in the data (i.e.) 0.5 m is half the smallest electrode separation, which is 1
m in the Z direction.
Since we have a relatively wide well-well separation of 7 m, we know we can probably use a corase mesh in X and Y.
However we are constrained by the element size in Z. Stability is compromised if we use a ratio > 2:1 for any cell
dimension. For optimal run speeds we can enter 1 m in both the X and Y directions.
Double click on the 0.5 value for Interior Grid Element X size (m). A separate menu is presented that permits changing of
the value to 1. Click OK to accept the change.

Double click on the 0.5 value for Interior Grid Element Y size (m). A separate menu is presented that permits changing of
the value to 1. Click OK to accept the change.
Scroll a little farther down the list to find Adapt Grid to Electrodes and change the value from 2 to 1 by double-clicking.
No other parameters in the configuration settings need to be changed for this model.
6. On the right side of the ERTLab Solver display notice the Survey Design Explorer menu. If this is not visible use View > Explorer
Window from the menu bar to select it.
In the explorer menu click Make Resistivity IP Model.
The resistivity IP model workspace will be presented.
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Change the background resistivity to 200 ohm-m and click Apply Background.
7. From the Survey Design Explorer select Make Mesh. The Mesh Workspace will be presented.
Since we already changed the X and Y element sizes in the foreground region, and we have no other changes to make click Apply
Settings.
The Make Mesh area is presented. There is a list of node locations and the ability to add nodes at selected places. Notice the list
is separated into - and + background nodes with foreground nodes listed in the center. Any node location may be changed by
double-clicking on it. Use the X, Y and Z buttons to switch between directions. Note that it is not usually necessary to make
changes to node locations, or to add nodes.
Click Make Mesh. The program works for a few seconds to a few minutes depending on processor speed and mesh size, then the
View Mesh bottun becomes available. Click View Mesh to look at your model.

Step 4: View the configuration with the ERTLab Viewer

1. If the View Mesh button did not automatically run the viewer then select the
viewer button to run the viewer or select the
ERTLab Viewer from the Start menu.
2. A file called ViewMesh.Dat was created in the ERTLab application directory.
Open this file using File>Open in the ERTLab Viewer.
The initial view of the model is looking down from the top.
Left click and hold on the screen and move the mouse to modify the Point of View (rotate the model).
Left click and hold while holding the shift key to pan the view.
Left click and hold while holding both the shift and ctrl key to zoom the view.
Click the
button from the toolbar to display the processing tool menu.
Select options like axes by clicking in the select box to modify the items shown.
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We will return to the viewer when the model is more exciting. For now simply exit.

Step 5: Prepare and run the forward model without the target.
1. Return to the FM Workspace by selecting FM Workspace from the Survey Design Explorer.
2. Under Forward Modeling
check the Model IP data checkbox.
Click run forward solver
The Progress Info box first indicates preliminary tasks, then forward modeling starts and the number of iterations and final
residual values are presented for each electrode.
Finally the forward model results are listed for each quadrapole.
the message ....Forward Modeling completed indicates the end of the task.
3. To save the data we must indicate the data columns in the Configuration settings.
Click Data I/O Config. from the Select Item: menu
Scroll down the master list until Item Description reads Calculated Res. Column
1. change from the default -1 to 10 by double clicking the value and entering 10 in the menu that pops up.
Scroll down the master list until Item Descripition reads Calculated IP Column.
1. change from the default -1 to 11 by double clicking the value and entering 11 in the menu that pops up.
4. The configuration settings may be saved with the data, or separately. To save the configuration settings separately click Save
Configuration in the Configuration settings area. To save the configuration with the data click the Include config. checkbox in the
Save Results area. For this tutorial please do both using the default for the configuration file and ForwardModelHalfspace.schd for
the data file name.
Notice the default extension of the configuration file is .cfg
Notice the default extension of the data file is .schd. Choose a file name like ForwardModelHalfspace.schd for the data file.

Step 6: Prepare and run the forward model with the target.
1. Return to the ERTLab solver.
2. Close the current project using File > Close Project from the file menu, or by clicking the X on any open workspace menu.
3. Start a new survey design project
survey design button.
From the choose File>New Project > Survey Design from the file menu or push the
4. Under Data input click on input Schedule. Find the file generated above (ForwardModelHalfspace.schd) and open it.
If the configuration settings were included with the file, they should be automaticaly loaded with the data. If not, then load the
configuration file (ForwardModelHalfspace.cfg).
5. Add the target
If the survey design explorer is not visible use View > Explorer Window from the menu bar to select it.
In the explorer menu click Make Resistivity IP Model.
The resistivity IP model workspace will be presented.
Make sure the background resistivity is 200 ohm-m
Add a resistivity and IP anomaly
In X min (m) type -100
In X max (m) type 100
In Y min (m) type -100
In Y max (m) type 100
In Z min (m) type -9
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6.
7.
8.

9.

10.

In Z max (m) type -7
In the Resistivity box type 50
In the IP box type .01
Push insert anomaly.
Notice the anomaly may be deleted but not changed. Also, the IP and resistivity anomalies are recorded independently, so they
must be deleted independently.
1. Select the IP anomaly and push delete. The IP anomaly is deleted. Push the resistivity button to confirm that the resistivity
anomaly.
Add a second resistivity and IP anomaly
In X min (m) type 2
In X max (m) type 4
In Y min (m) type 2
In Y max (m) type 4
In Z min (m) type -9
In Z max (m) type -7
In the Resistivity box type 200
In the IP box type 20
Push insert anomaly.
The combination of these anomalies produces a resistivity layer with a hole. The hole is filled with a chargeable body.
Return to the FM Workspace by selecting FM Workspace from the Survey Design Explorer.
Save the configuration (ForwardModelWithTarget.cfg)
Under Forward Modeling
make sure the Model IP data checkbox is checked.
Click run forward solver
The Progress Info box first indicates preliminary tasks, then forward modeling starts and the number of iterations and final
residual values are presented for each electrode.
Finally the forward model results are listed for each quadrapole.
the message ....Forward Modeling completed indicates the end of the task.
To save the data we must indicate the data columns in the Configuration settings.
Click Data I/O Config. from the Select Item: menu
Scroll down the master list until Item Description reads Calculated Res. Column
1. change from the default -1 to 10 by double clicking the value and entering 10 in the menu that pops up.
Scroll down the master list until Item Descripition reads Calculated IP Column.
1. change from the default -1 to 11 by double clicking the value and entering 11 in the menu that pops up.
The configuration settings may be saved with the data, or separately. To save the configuration settings separately click Save
Configuration in the Configuration settings area. To save the configuration with the data click the Include config. checkbox in the Save
Results area. For this tutorial please do both using the default for the configuration file and ForwardModelHalfspace.schd for the data
file name.
Notice the default extension of the configuration file is .cfg
Notice the default extension of the data file is .schd. Choose a file name like ForwardModelWithTarget.schd for the data file.

Step 7: Compare the models in Excel or other Spreadsheet.
1.
2.
3.
4.
5.
6.
7.

Open the two files ForwardModelHalfspace.schd and ForwardModelWithTarget.schd using Excel or similar spreasheet.
Notice that because the data portion of the files is tab delimited the data are automtically separed into columns.
Copy the two files to separate worksheets in the same spreadsheet.
Create a third worksheet to perform the compares.
Create difference and percent difference columns.
Bin the data and create histograms or analyse by simply sorting on the difference or percent difference columns
Using knowledge of instrument sensitivity it is possible to make judgements about the detectability of the target.

Step 8: View the model with target using the viewer.
1. In the FM Workspace click IP, then click View Model.
viewer button to run the viewer or select the
If the View Mesh button did not automatically run the viewer then select the
ERTLab Viewer from the Start menu.
A file called ViewMesh.Dat was created in the ERTLab application directory (save for reference in the tutorial subdirecty as
ViewMeshIP.dat).
Open this file using File>Open in the ERTLab Viewer.
The initial view of the model is looking down from the top.
Left click and hold on the screen and move the mouse to modify the Point of View (rotate the model).
Left click and hold while holding the shift key to pan the view.
Left click and hold while holding both the shift and ctrl key to zoom the view.
Click the
button from the toolbar to display the processing tool menu.
Select options like axes by clicking in the select box to modify the items shown.
Click the
section button to add a section.
In the submenu that appears click YZ section, remove the show lines check under contours, turn clipping off and change
the mode to cell scalars as shown
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Insert another section, this time selecting XZ with all the other choices indicated above.
Insert another section, this time selecting XY with all the other choices indicated above.
The display should be similar to the following

Sections may be moved by selecting the appropriate section in the Post-process tool bar then pressing the
arrow buttons, or by direction entering a position.
In the FM Workspace click Rho, then click View Model.

double

If the View Mesh button did not automatically run the viewer then select the
viewer button to run the viewer or
select the ERTLab Viewer from the Start menu.
1. A file called ViewMesh.Dat was created in the ERTLab application directory (save for reference in the tutorial
subdirecty as ViewMeshRho.dat).
2. Open this file using File>Open in the ERTLab Viewer.
3. The initial view of the model is looking down from the top.
4. Left click and hold on the screen and move the mouse to modify the Point of View (rotate the model).
5. Left click and hold while holding the shift key to pan the view.
6. Left click and hold while holding both the shift and ctrl key to zoom the view.
7. Click the
button from the toolbar to display the processing tool menu.
8. Select options like axes by clicking in the select box to modify the items shown.
9. Click the
volume button to add a volume.
10. In the submenu that appears insert 50 in the min area and 60 in the max area.
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11. The display should be similar to the following

12. Notice that because cell scalars are not available for volumes, the viewer has 'smoothed' the edges of the hole so
that it appears larger than it really is, and rounded. Similarly the layer is thinner than it actually is. This may be
confirmed by increasing the max value for the volume from 60 10 100, in which case graded colours will appear
showing the rest of the volume. This effect is purely an artifact of the 3D engine chosen. The actual model used in
the Solver is the one that was input.

Step 9: Invert the forward model with the target.
The ultimate way to check the resolving ability of the array and electrode layout used is to perform an inversion of the forward results.
1. Close the survey design project
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.
13.
14.
15.
16.
17.
18.
19.
20.
21.
22.

Use File>New Project > Data inversion or the
data inversion button to start a new inversion project.
Scroll down the configuration settings list to find the IP data column item and change from the default -1 to 11.
Click Input schedule and select the ForwardModelWithTarget.schd.
Select mesh settings from configuration settings Select Item List.
Adjust Interior Grid Element X Size (m) to 1.
Adjust Interior Grid Element Y Size (m) to 1.
Leave Interior Grid Element Z Size (m) at 0.5.
Set Adapt grid to electrodes to 1 (Yes)
Scroll to Inversion Parameters
Set Simple Inversion to 2 (No)
Set Maximum Internal PCG Iterations -Rho to 12
Set Maximum Internal PCG Iterations - IP to 20
Scroll to Noise
Set Rho Data Percent Errors to 3 %
Set IP Data Percent Errors to 10 %
Set Use Robust Inversion (data errors reweight) to 2 (No)
Scroll to Saving and Plotting parameters and set Save inverted model for each iteratino to 2 (No).
In the inversion area select the IP inversion checkbox.
Save the configuration as Inversion.cfg
Click Run Data Inversion
Change the progress file name to Inversion.prg

57

23. The inversion will proceed and results will be presented in text form in the progress window box and in graphical form in the Inversion
progress graph. Notice that for each iteration there will be several trials (up to 4) performed in selection of the optimal roughness
factor. If simple inversion was chosen then the selection of optimal roughness factor only occurs for the first iteration, then the
roughness factor is simply deccreased by a factor equal to the parameter 'Multiplier for changing roughness factor (in rho and IP). This
parameter is usually set to 10.
24. Notice that the Resistivity inversion proceeds first and is completed before the IP inversion starts.
25. If all parameters and anomalies were set as described, then this inversion will complete in 3 iterations for both resistivity and IP.
Elapsed time will be on the order of 15-30 minutes, depending on processor speed.
26. The ultimate screen at completion of the IP inversion is shown below.

Step 10: View the inversion with the ERTLab Viewer.

1. Close the Inversion progress window by clicking the X in the upper left or by clicking the activation button
.
2. To save the mesh for viewing:
In the SAVE RESULTS area of the DI workspace click Rho, then click save model. Assign an appropriate name such as
InversionRho.dat. If the Save XYZ file checkbox is selected then an XYZ file is written having resistivity values posted at each
node of the inversion mesh.
In the SAVE RESULTS area of the DI workspace click ip, then click save model. Assign an appropriate name such as
InversionIP.dat. If the Save XYZ file checkbox is selected then an XYZ file is written having IP values posted at each node of the
inversion mesh.
3. To save the modeled results for each quadrapole:
In the CONFIGURATION SETTINGS area scroll to Data input / output format, find calculated Res. column and change this from -1
to 12.
Find the calculated IP column parameter and change this from -1 to 13.
In the SAVE RESULTS area click Save Schedule and assign an appropriate name such as Inversion.schd
4. To view the IP model, under MESH Parameters select IP then click View Model, or run the viewer using the
open the InversionIP.dat file saved above.
Rotate and position the image as before.

viewer button, then

Click the
button from the toolbar to display the processing tool menu.
Select options like axes by clicking in the select box to modify the items shown.
Click the
section button to add a section.
In the submenu that appears click YZ section, leave show lines checked under contours, turn clipping off and leave the mode as
contours as shown
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Insert another section, this time selecting XZ with all the other choices indicated above.
Insert another section, this time selecting XY with all the other choices indicated above.
The image should look like one shown below:

5. To view the Rho model, under MESH Parameters select Rho then click View Model, or run the viewer using the
then open the InversionRho.dat file saved above.
Rotate and position the image as before.

viewer button,

Click the
button from the toolbar to display the processing tool menu.
Select options like axes by clicking in the select box to modify the items shown.
Click the
volume button to add a volume.
In the submenu that appears leave the min Rho value alone and insert 60 in the max area.

The display should be similar to the following
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ERTLab Sequencer
Introduction
The ERTLab Sequencer is used to create arrays and sequences for a range of survey configurations.
Because of the complexity of creating sequences for 2D and 3D surveys, the sequencer includes tools to
view the electrode locations and array sequences in 3D (Quadrupole List) and to show a half space and
geometric factor plot location (Quadrupole View) that provides an idea of the focus of data collected at
any given quadrupole. Similarly, because 3D data collection is typically highly redundant and voluminous,
QC Tools such as incorporation of reciprocals and removal of duplicates are included. In addition to this
help file, most buttons, input boxes and controls have 'tool-tip' help. If you hold the mouse over the control
without clicking for slightly more than a second, then a small menu describing the function of the control
will be presented.
To build a sequence:
1) Input the electrode locations. These are usually logically grouped as one or more cables
(survey lines or wells) each with one or more evenly spaced electrodes.
2) Build a sequence containing one or more array types.
3) Save the sequence to be downloaded to a field system or input into a forward model for survey
design.

Menu Bar
File Menu Item
The file menu permits opening and saving files in several formats including ERTLab native format, Electre
text format and MPT format.
Layout Menu Item

Unless an existing sequence file has been imported, the place to start is the Layout menu. First select
Cables. The cable entry screen will be presented. Grid and coordinate list are not currently implemented
and make sequences is the same as selecting the items from the Sequence menu. Electrodes displays a
list of electrodes.
Cable Entry

Electrodes are grouped by Cable (logically equivalent to a survey line, well or physical cable with multiple
takeouts). Start with an electrode distribution on the first cable (along the first survey line or in the first
well). Count is the number of electrodes on this cable. To insert a new cable in the layout, specify the
number of electrodes for the cable (count), and the spacing. After making changes for any entry please
push enter to update the linked parameters. The spacing control updates the X end coordinate unless the
borehole checkbox is checked, in which case the Z end coordinate is updated. When the insert button is
pushed the electrode distribution is displayed and the logical group is indicated by the electrodes being
joined by a line. Alternatively, the start and end of the cable (cable start and cable end) may be set using
XYZ coordinates in meters. To insert cables underground the Z value should be negative. Surface is
1

assumed to be 0 and topography is not considered. Topography may be added later in the forward
workspace for forward modeling and in the inversion workspace for inversion.
It is possible to include up to two remote electrodes. These are input by selecting the checkboxes and
entering the appropriate X, Y and Z coordinates.
The ERTLab coordinate system employs a right-handed coordinate system with 'Z' positive up. For
borehole electrodes, the calculation of the geometrical factor K is influenced by the depth of burial of the
electrodes. On insertion, the new cable will is displayed in red in the 3D view window.

The 'Move Cable' frame contains buttons that facilitate moving the selected cable. This menu works on
the highlighted (red) cable. To highlight a cable double-click on any of its electrodes. The standard
displacement is equal to the cable electrode spacing and the cable may be moved in any direction by
clicking the appropriate arrow. By holding the [Shift] key the displacement is reduced to one tenth the
cable electrode spacing. Holding the [Ctrl] key, results in the standard displacement multiplied by a factor
ten. Watch the cable start and end coordinates to see the effect of moving the cable. To re-center the 3D
display screen check the Grd. Auto checkbox.
The two buttons
and
, flip the cable vertically and horizontally, respectively. These are useful for
reversing the cable electrode numbering direction.

Between the cable definition and move menus is the cable insertion menu. The four buttons on this menu
permit inserting a cable, updating its coordinates, removing a cable or removing all of the cables. The
update cable button is not active unless some parameter in the cable definition menu has been changed
(XYZ start or end, or electrode count or spacing). Update cable and Remove affect the selected (red)
cable. Note that insert places a cable according to the parameters in the cable definition area. If this has
not been changed from the previous insertion, then the new cable will plot exactly on top of the previous
cable and it may not appear that two cables are present. Check the cable count in the lower right corner
of the cable entry dialog to determine the number of cables present.
Grid Entry
A different way to insert electrode on a layout is using a grid. User will define max number of columns and
max number of rows in a “electrodes matrix”, distance between columns and rows can also be defined
(default is 1 m). The button [Grid] will create onto the graph window a grid as specified. Electrodes
number would be inserted into cells with left click. Each left click will increment counter of 1, rgth click of
about -1. When the insertion is completed click on [Create Elec.] button and the program create a single
cable with electrodes specified in the grid.
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Grid entry

Single cable created with grid entry mode
3

3D view

Four parallel cables (16 electrodes per cable) with a surface grid

A 3D graph picture box is always visible in the lower part of the window. Some controls are available
near the view itself, such as [Zm X] (Zoom in X); [Zm Z] (zoom in Z), Reset and grid controls. Others are
available on a separate menu. Other controls near the view are the [Grd. Auto] check box, which
recenters the view when switched on, and five boxes that control surface grid display. These boxes
control spacing, and extent of the surface grid display.
Using the mouse the 3D view may be rotated, panned and zoomed. Combinations of left mouse key, right
mouse key and the keyboard shift, control (ctrl), and alt buttons perform different functions. These are
documented in the table below.
Event
LeftMouseDown

Key

Shift
RgtMouseDown
LftMOuseDown
LftMouseDown
RgtMouseDown
DblClick
LftMouse
RgtMouse

Motion.
Horizontal
Vertical
Horizontal
Vertical

Ctrl
Alt
Shift
Shift
Shift

Over electrode
Over electrode
Over electrode

Action
Rotate around vertical Axes (Z)
Rotate around horizontal Axes (X)
Rotate around Y axes (orthographic)
Zoom in / zoom out
Drag Image
Select area
Adjust focus in perspective view
Select cable
Toggle elec. Used
Edit electrode coordinates

In addition to the mouse controls a menu with certain view options is presented.
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Switch between orthographic and perspective views using the toggle buttons [Ortho.] and [Persp.] Snap
to XY, YZ and XZ views using the push buttons on the right of the menu. Subtle rotations about X, Y and
Z axes are possible using the increment buttons or by directly entering an angle. The effect of these
controls is as follows:
[Theta]:
[Gamma]:
[Phi]:

is the angle around X axis (X is horizontal and positive to the right)
is the angle around Y axis (Y is a horizontal line projecting outward from the plane of your
computer screen).
is the angle around Z axis (Z is vertical with positive upward).

In addition these subtle controls are implemented for zoom using the buttons or value entry. Larger
values zoom out (make the image smaller) and smaller values zoom in (i.e. the value acts more like a
scale factor than a zoom.)
Check boxes are available to display different attributes of the cables, electrodes and data window.
Cables Checkbox:
Grid Checkbox:
Quad. Checkbox:
Box Checkbox:
Lbl Checkbox:

Show/hide connection lines between electrodes in cable.
Show/hide a surface grid spaced as specified in the [Grd. Spc.] text box.
Show/hide quadrupole plot points in the graph window.
Show/hide a box at the coordinate extremes in the graph window.
Show/hide labels at the corner of the box.

In addition the display of electrodes on the cables has several options. Graphical presents the electrodes
as dots, electrode ID displays the electrode number at each location, Cable and electrode
ID presents Cable_Electrode numbers at each location and none turns electrode display off.
Electrode List
The electrodes list is shown by clicking the “electrodes” menu item from the Layout menu.

When scrolling through the electrodes list the selected electrode is highlighted on the 3D View.
By pressing the left mouse button while holding the ctrl key it is possible to select a group of electrodes.
Electrodes inside the selected region will turn blue. Blue electrodes can be set/reset as Roll or Skip. Skip
(usd = 0) means that quadrupoles using this electrode will not be scheduled. This is useful for bad
electrodes, or when limited time for data collection is available, or when testing array patterns for
resolving capability. The roll setting (Roll = 1) is for cable overlap. Quadrupoles where all electrodes with
the roll flag set to one will not be inserted in the schedule. Use this option to create a Roll-Along sequence
Sequence generator
5

Three items are available on the sequence menu. Make surface sequences is used to create sequences
where surface electrodes alone are employed. Make multi-borehole sequences is used when borehole or
borehole and surface electrodes are used. View Quadrupole list displays a list of the sequences that have
been created. Multi-borehole sequences may only be generated on cables having electrodes with
negative 'Z' coordinates. It is recommended that the borehole checkbox be selected when borehole
cables are being developed. Separate menus are available to make the interface as intuitive as possible
for each survey type.
In many respects the function of the two menus is similar. In each menu toggle buttons are available for
various array types. These are arranged across the top of the menu area. More than 1 array type may be
chosen, however for best control it is recommended that only one array type be chosen at a time. In each
case the common array terminology 'a' and 'n' is implemented, however 'a' spacing is implemented in
terms of the cable electrode spacing. ie for cables having an electrode spacing of 3 m, an 'a' spacing of 1
would represent a 3 m dipole, and an 'a' spacing of 2 would represent a 6 m dipole. 'n' spacing are
implemented in the usual manner as multipliers for the 'a' spacing that represent transmitter and receiver
separation. The button
is used to add a sequence to the list. Each time this button is pressed a
sequence based on the parameters chosen is created and appended to the existing sequence list. The
sequence list may be viewed at any time by pressing F11, or by selecting the 'View Quadrupole List'
menu item. The button
is used to completely clear the sequence list. At this time there is no ability to
remove only 1 sequence. Finally, kGeom. may be used as a threshold to ignore quadrupoles with small
geometric factors. This is useful to avoid wasting time collecting data that will likely have very small
received voltages and thus be noisy and unreliable. The default value of '0' writes all quadrupoles to the
list regardless of geometric factor.

Surface scheme

In the surface scheme dipole length ('a') spacings are specified in a list, use of multiple 'a' spacings is
facilitated using a simple list. (For a more traditional approach simply specify a single 'a' spacing - e.g. 1
in both the transmitter and receiver areas. Similarly 'n' spacings (nL box) are explicitly requested using the
list area. For a short definition of the ‘a’ or ‘nL’ list, is possible to use a very simple syntax: “1:10” means
all integer number from 1 to 10, “2:2:10”, means all even number form 2 to 10.
The arrow checkboxes and common and different cable toggles interact. By toggling common cable, the
arrays created have transmitter and receiver dipoles aligned in a single direction (i.e. the transmitter and
receiver are arranged in a straight line). If different cables toggle is set then the transmitter and receiver
dipoles cannot be aligned in a straight line. The arrows checkboxes are set independently for the
transmitter and receiver. The horizontal arrows result in common cable dipoles. The vertical arrows result
in dipoles with matching electrode numbers on two separate cables. The diagonal arrows are similar to
the vertical arrow except that electrode numbers are incremented or decremented by the 'a' spacing
selected. If common cables and the horizontal arrows are chosen then a traditional array, arranged along
a survey line is sequenced. If common cables and vertical arrows are chosen then the same, aligned,
traditional array is arranged perpendicular to the survey lines as shown below. In this case only 16
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quadrupoles are created because there are only 16 positions which can supported this aligned,
perpendicular array. However if Tx and Rx on different cables is toggled, then 1536 quadrupoles are
created, because all the offset perpendicular arrangement are generated as shown in the second figure.
The display of transmitter and receiver dipoles shown in these figures is accomplished using the
Quadrupole View described below.

Creation of a simple sequence would include the following steps:

1 – Select the array type using the push buttons (dipole-dipole, wenner etc. - multiple selections are
allowed)

2 – set the transmitter dipole size and direction parameters.

3 – set n list and constraint for geometric factor

4 – toggle common or X-cable arrays
5 – Push the
button to generate the sequence.
6 – Push F11 or select View Quadrupole List from the Sequence menu.
7 – Repeat steps 1-5 to generate as many sequences as required.
6 – Save the sequence.
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Examples of array types shown below employ diagonal array development to enhance clarity. The display
of transmitter and receiver dipoles shown in these figures is accomplished using the Quadrupole View
described below.
[Pole – Pole]

Create a Pole – Pole sequence. Remote will be B and N.

Pole-pole, a = 3, diagonal 1

[Pole – Dipole]

Create a Pole – Dipole sequence. Remote will be B.

Pole – Dipole, a = 1, nL = 3, diagonal 1
[Line Dipole-Dipole] Create a Dipole – Dipole sequence.

Dipole – Dipole, a = 1, nL = 1, diagonal 2

Dipole – Dipole, a = 1, nL = 2, diagonal 1

[Wenner]

Create a Wenner sequence. Use the transmit parameters and specify every
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a you need to include in your sequence

Wenner, a = 1, diagonal 1
[Wenner Schlumberger]

Create a Wenner Schlumberger sequence. Use the transmit parameters and
nL

Wenner Schlumberger, a = 1, nL = 3, horizontal
[Gradient Array]

not yet implemented

[Parallel Dipole Dipole]

not yet implemented

Create a Roll – Along sequence
In order to create a Roll-Along sequence, set the roll flag of electrodes that will not repeat to 1, meaning
that quadrupoles with all non-remote electrodes with Roll flag set to 1 will not be included in the list.
In the case of a 32 electrode cable,
-

to “move the cable” every 2 electrodes, in order to create a roll – along sequence, electrodes
from 1 to 32 must have the roll flag to 1
to “move the cable” every 16 electrodes, in order to create a roll – along sequence, electrodes
from 1 to 16 must have the roll flag to 1
To show the plot locations as shown see Quadrupole view below.

32 electrodes. Wenner sequence – Roll-Along of 16 electrodes
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Quadrupole List

The quadrupole list is available by pressing F11 or selecting View Quadrupole List from the Sequence
menu. The transmitter (red electrodes) and receiver (green electrodes) dipoles are highlighted by
selecting using the mouse any quadrupole in the list.
Quadrupole View
Quadrupole view is selected by checking the quad. checkbox. An idea of focus for any quadrupole is
provided by plotting a single circle representing each quadrupole in 3D space following a simple rule. In
surface configuration (all the electrodes have Z coordinate zero or positive), the XY coordinate of each
quadrupole is determined by an average over the XY coordinate of the non-remote electrodes in
quadrupoles and the Z coordinate is determined by level order. The levels are sorted by the absolute
value of the K geometric factor.
In cross-line configuration (at least one electrode has a negative Z coordinate), the XYZ coordinates are
determined following this heuristic rule: the quadrupole plot point lies in the line joining the mid point of the
current dipole and the potential dipole, quadrupoles are sorted by the absolute value of K, lower K plots
closer to current dipole. The idea is to provide an indication of coverage, resolution and redundancy
available in the sequence generated.
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Heuristic representation of Cross-Hole Dipole - Dipole sequence (a=1, 2, 3)

Heuristic representation of Cross-Hole Dipole Dipole sequence
(a=1. A=1, B=2, MN=16-17 à 31-32)

Linear Dipole-Dipole a = 1 nL = 5, all directions

Tools
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The tools menu is accessed from the main menu bar. The tools are arranged in two categories. The first
is optimization. Some resistivity meters can carry out measurements using multiple channels. That is data
from multiple receiver dipoles may be collected during energization of one transmitter dipole. In most
cases appropriate arrangement of the schedule file is required to implement this functionality. The
Optimize button in ERTLab is specific to the IRIS Syscal which requires dipoles on sequential channels to
be linked by a common electrode.
The second category is for QC and to remove redundancy. If multiple types of sequences have been
generated, it is possible that some duplicates were created. pressing the remove duplicates button
removes all duplicate readings. Due to the high data volumes typically collected for ERT, traditional,
manual QC is practically impossible. One useful trick is to collect reciprocal data. Reciprocal data have
the transmitter and receiver dipoles swapped. Reciprocity states the two readings should be identical.
Comparing reciprocal data can identify such problems as high contact resistance, cultural noise,
intermittent connections and instrumentation problems such as poor grounding or failed components. We
highly recommend that data intended for interpretation through inversion be collected reciprocally.
ERTLab solver provides tools for analyzing the reciprocal data for problems.
Input Output options

The Open and Save options are accessed from the File menu on the main menu bar. The four options
indicated save ASCII files. Cables saves only the electrode locations. ERTLab format is for the ERTLab
solver. Electre format is for the Syscal instrument manufactured by IRIS instruments of France. MPT
format is for the EIT2000 series of resistivity meters manufactured by Multi-Phase Technologies, LLC in
the United States.
Multi-borehole scheme

In the multi-borehole scheme dipole length ('a') spacings is set once and is the same for both transmitter
and receiver. Use of multiple 'a' spacings is facilitated through a simple list. (while developing an
understanding of sequencer operation it is recommended that a single 'a' spacing - e.g. 1 is chosen as
this vastly decreases the number of quadrupoles generated). 'n' spacings are explicitly requested using a
second list area and are separately requested for common and cross (different) cable sequences. Since
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there is currently no way to simply specify all possible 'n' spacings, make the list as long as necessary to
include the data required.
The V and H checkboxes and common and cross cable checkboxes interact. If only common cable is
selected, the arrays created have transmitter and receiver dipoles aligned in a single direction (along the
common borehole in the case of common cables and at a common elevation in the case of horizontal
dipoles). If different cables toggle is set then the transmitter and receiver dipoles cannot be aligned in a
straight line. The H and V checkboxes are set independently for the transmitter and receiver permitting 'L'
shaped arrays. The V checkboxes result in common cable dipoles. The H checkboxes result in dipoles
with matching electrode numbers on two separate cables. If common cables and the V checkboxes are
chosen then a traditional array, arranged along a borehole line is sequenced. If cross cables and H
checkboxes are chosen then 3D horizontal dipoles are collected as shown below. The display of
transmitter and receiver dipoles shown in these figures is accomplished using the Quadrupole View
described below.

In some cases many boreholes are present, or some are so far apart that creating sequences between
them is meaningless. In order to create sequences for sub systems, it is possible to create and work with
groups of cables. To create a group simply list the cable ID's (each cable is determined by an integer
number) and click 'add' to add the group to list of groups. Select any group from the list to work with it.
The sequence will be created only for cables specified in “List of Groups”.
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Creation of a simple sequence would include the following steps:

1 – Select the array type using the push buttons (dipole-dipole, wenner etc. - multiple selections are
allowed)

2 – set the transmitter and receiver dipole size
and direction
parameters.
The kGeom. constraint sets a threshold below which quadrapoles will not be generated. This is useful to
eliminate quadrupoles that will likely read very small values.

3 – set n list and common or cross cables (or both).

4 – Push the
button to generate the sequence.
5 – Push F11 or select View Quadrupole List from the Sequence menu.
6 – Repeat steps 1-5 to generate as many sequences as required.
7 – Save the sequence.

ERTLab Format
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The ASCII file is divided in two parts. A description of electrode layout and the quadrupoles list. Each
section start and ends with e “Tag”
Tag
#elec_start

Columns
N. cable, N. electrode, X, Y, Z coord, Z ground

#elec_end
#data_start
Progressive, n. cable, A, n. cable, B, n. cable, M, n. cable, N
#data_end

IRIS Format
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The ASCII file is divided in two parts. First a description of electrode layout, after the quadrupoles list
Line
1
2 to N electrode
3 + number of electrodes
4 + number of electrodes

Columns
Header
N, X, Y, Z
Header
N_item, A, B, M, N

For input sequence file must have one of the format sketched above. Otherwise an error is generated.
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ERTLab Viewer

The ERTLab Viewer provides a user-friendly 3-D visualization environment capable of spinning the 3D model, viewing
sections, planes, volumes, and shells with contouring and simple labeling.

1. Starting the Viewer
The Viewer may be started from the ERTLab Solver environment by pushing the viewer button of the main toolbar or
selecting the menu item Tools > ERTLab 3D Viewer.
Alternatively the Viewer may be started from the Windows Start Menu by selecting the ERTLab Viewer icon.
The Viewer is also started automatically when the ViewMesh buttons are pushed from the ERTLab Solver Forward modeling
workspace, Inversion Workspace or MakeMesh workspace.

2. Introduction to Controls
Like most MS-Windows software, the ERTLab Viewer environment is navigated using a system of menus or toolbar
push-buttons.

2.1 Menus
In the system menu the following items are available:
File - Use the file menu items to open a file, to perform the printing tasks, to exit the program or to work with script
files.
Scripts (saved and executed from the File menu) preserve information about point of view, zoom level, sections, volumes
and shells displayed or available for display, color ranges and bitmap generation. Scripts are useful to preserve project
views for future use and may be used to open new files using the same parameters that were prepared for a previous
version of the model.

View - This menu item presents a list of toolbars which may be turned on or off (checked).
The Window button shrinks or expands the active window.
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2.2 Toolbar controls
The toolbar provide access to the follwing tasks:
Open file button.
The screen capture button permits capture of the document area of the active ERTLab Viewer window. The toolbars
and menu are not included. A Microsoft format .BMP file is created at the resolution of the screen.
The printer button send the document area of the screen to any windows printer.
Click the post-processing toolbar button displays a floating menu with visualization controls that will be described
below. Click the button a second time to hide the floating menu.
buttons work together to toggle the response of the mouse. The default is interact which
The select and interact
provides perspective control over the model view. In interact mode the model is rotated, panned and zoomed depending on
mouse clicks and movements. In select mode the mouse is pointed at an item on the screen. Left click results in display of a
menu that permits some control over items displayed on the screen.
The perspective checkbox toggles between perspective and orthographic displays. Perspective presents a
more intuitive 3-D presentation and is the default. Orthographic presentation is good for 2-D section and plan
views where distances will be measured.
The X, Y and Z snap buttons orient the presentation so the viewer is located directly along the selected
principal axis. This is useful for 2-D presentation of the model.
The snap to default zoom button restores the initial zoom of the model.
Save current view provides the ability to save a particular perspective, zoom and
rotation as a named view. The List of named views become available in the
drop-down box to the right of the Save Current View button. To save a view click the Save Current View button and provide
a name. To return to the saved view select the name from the list. Using the mouse, click on the arrow button to see the
list.
The resistivity / conductivity drop-box toggles between resistivity (the default) and conductivity (=
1/resistivity))
Pushing the POV button displays the point-of-view menu which permits return to an exact view. This is useful when
opening a sequence of files for the same model. On opening a new model the current views are lost, but may be
recovered by recording the POV information.

The POV values are the coordinates of the viewer. These change when the model is rotated. The Focal point values are the
coordinates of the center of the screen. These change when the model is panned. The View-up-Vector is the vector to the
top of the screen. Changing these values changes the orientation of labels with respect to the Cartesian axes. The
perspective distance provides an indication of zoom. When the perspective checkbox is off, this control may be edited.

2.3 Zoom, pan and rotate
To rotate using the mouse: left click and hold while moving the mouse.
To pan using the mouse: hold the shift key down, left click and hold while moving the mouse.
To zoom using the mouse:
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hold both the shift and ctrl keys down, left click and hold while moving the mouse
or
right click and hold while moving the mouse.

3. Post-processing toolbar
The post-processing toolbar is used to control and modify the features displayed. On opening a model the electrodes are
presented as red spheres and the model area is enclosed in wireframe box. The post-processing control permits addition of
sections, volumes, shells, control of the color bar, and
addition and removal of axes, labels, color scale bar
and the electrodes.
There are four areas of the toolbar.
The Main window shows items displayed and
switches the feature control to the selected
(highlighted) item.
The Vertical toolbar is used to add new items to the
main window.
The Feature control area is specific to the selected
item in the Main window.
The color range displayed applies to all objects and
controls the distribution of the color palette.
In the main window, items currently displayed
are checked
Turn options such as color scalar bar, axes and
electrodes on and off by clicking the associated
checkbox.
The vertical toolbar to the left the of main
window inserts

sections, isosurfaces

,

and labels
. Up to 10 of each
volumes
of these features may be inserted. As each item
is inserted it appears under the appropriate
subheading in the main window on the toolbar.
For example, one section is present in the
toolbar shown here, no isosurfaces or volumes
are present.
Each individual section, volume, etc. has its own check box that controls whether it is displayed or not. In addition,
the entire suite of Sections, volumes, etc. may be turned on and off using the associated checkbox.
As each individual item is inserted (using the vertical toolbar) a sub-menu is presented. This is the same menu that
is available after insertion in the feature control area. To adjust the feature controls first select the item in the Main
Window by left clicking on it using the mouse.
To adjust the color range display change the min and max data visualization properties. The colors of the color bar are
distributed across the min-display-max range. The min and max for the dataset are shown in the grayed out boxes to
the extreme left and right of the data visualization properties area.
Feature controls that apply to the overall item suite are available by clicking on the main heading under visual items.
For example, clicking on the section heading displays a contour menu in the Feature control area; and clicking on the
Scalar bar heading displays a selection of linear or Log-10 and reversed color distributions.

4. Feature Control Menus
This section describes feature control menus that are displayed in the feature control area of the post-processing toolbar
when master headings or individual items are selected by left-clicking on them using the mouse. Some of these menus are
also displayed as individual items are inserted using the vertical tool-bar in the post-processing menu.

4.1 Scalar Bar feature control
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Two color bars are available in ERTLab, a typical rainbow distribution from cold, blues and greens through warmer
yellows and reds, and the RB color bar from cold shades of blue through white in the center to warm shades of red. The
controls labeled Linear, Log 10 and Inverted Linear control the rainbow color distribution and the controls labeled Linear
RB and inverted Linear RB control the Red-blue color distribution. There is no Log 10 distribution available for the red-blue
color bar.
To change the range of values over which the color bar chosen is distributed change the min and max displayed in the data
visualization properties area of the post-processing toolbar.

4.2 Axes feature control

The Axis feature contol allows the user to change the location, length, and display of the Cartesion coordinate axes. By
default, the axis extend from the minimum to the maximu boundaries of the mesh in the X, Y and Z direction and contain
labels and ticks at five locations.

4.3 Electrodes feature control

A slider bar that controls the size of the electrodes is available. To make the electrodes larger left-click on the slider using
the mouse and drag it toward max.

4.4 Sections heading feature control
Click on the master sections heading to display the contour control. The default is automatic distribution of 32 contour
levels.
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To adjust contour levels:
1. Click User defined
2. Adjust the range of values over which the contours are distributed by changing the min and max displayed in the data
visualization properties area of the post-processing toolbar.

3. Change the number of contours
4. Press apply. The values will be automatically calculated.
5. Any individual value may be changed by clicking on it once. The display of the value will change to a highlighted box.
A known issue is that the value must be changed or the viewer will crash.
6. Press apply after the values have been changed.

4.5 Individual Sections Feature control

- Each section must be assigned a unique name. The default is that each section is named sez1, sez2, and so on.
- Direction control is as follows:
XY is a plan presentation. Elevation of the plan is controlled by the Z position.
YZ is a vertical section in the YZ plane. X location of the section is controlled by the X position.
XZ is a vertical section in the XZ plane. Y location of the section is controlled by the Y position.
Vertical creates a vertical section. Position controls include centers in X and Y and an azimuth.
Any creates a randomly oriented section. Position controls are XYZ center of the section, and nX, nY, nZ control a
perpendicular to the section plan. For example nZ=1, nX = nY = 0 creates a horizontal plan. nZ = nX = nY = 1
creates a diagonal from corner to corner of the model.
- Contour lines may be shown or not, contour values may be shown or not by using the mouse to check the boxes.
- Clipping on sets the colors outside the display range to white. Clipping off sets colors outside the displayed range to the
hottest or coldest color as appropriate. Adjust the range of values over which the contours are distributed by changing the
min and max displayed in the data visualization properties area of the post-processing toolbar.

- Mode provides three choices, the default is contours. Other choices are cell scalars and node scalars.
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Contours threads contours between node values and provides a smoothly varying color scheme. This is usually the
best presentation for typical inversion result (see i below).
Cell scalars assigns a single average value to each cell of the model. This presentation is used to visualize the
resolution of the mesh and is more appropriate than contours or node scalars for models with sharply defined edges
and boundaries such as a typically present in a forward model. This is usually the best presentation for a typical
forward model (see ii below).
Node scalars smoothly distributes colors between nodes. It provides an alternative view to the smoother contours.

- The opacity control may be used to 'see through' the section feature.

4.6 Individual Isosurfaces feature control

- Each isosurface must be assigned a unique name. The default is that each isosurface is named iso1, iso2, and so on.
- The control produces a 3-D shell, which may be thought of as a 3-D contour, threaded to join the Iso-value chosen.
- The opacity control may be used to 'see through' the isosurface feature.
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4.7 Individual Volumes feature control

- Volumes may be named.
- A volume is created for the range specified. Since volumes may take some time to calculate, it is usually best to start
with a small range, then expand it. One presentation we find informative is to create two volumes, one at the high end of
the model range, and one at the low end of the model range.
- Adjust the range of values over which the contours are distributed by changing the min and max displayed in the data
visualization properties area of the post-processing toolbar.

- The opacity control may be used to 'see through' the volume feature.

4.8 Individual labels feature control

- Labels may be named.
- The position, size and color of the label may be controlled.

5. Script controls
Script controls are used to save a model workspace for future viewing or to view alternative versions of the same mesh
(some examples are: IP vs resistivity, alternative inversions produced using different parameters, or sequential periods of
data collection).
To save a script select File> Save to script file from the File menu.
To run a script click File > Execute script file from the File menu.
To run a script changing the input mesh file name choose File > Execute script changing data... from the File menu.
A script file is an ASCII text file.The script file must comply with the following syntax:
The first line MUST contain the keyword FILENAME followed by the name of the data file.
FILENAME \\NetworkComputer\Directory1\SubDirectory1\SubDirectory2\Filename.vwer
Following lines can contain any of the following keywords in any order, followed by the corresponding parameters in
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the given order. A line beginning with # is a comment (the first line, containing the FILENAME keyword, cannot be a
comment). The supported keywords and the corresponding parameters are:
FILENAME "filename"
Specifies the data file name.
"filename" is a string containing the name of the data file.
SPLASHSCREEN t
Shows the splash screen (that cannot be automatically shown at startup since it would stop the execution of the
script).
t is an integer value that specifies how long the splash screen will be shown in milliseconds.
SECTION "name" dir_x dir_y dir_z orig_x orig_y orig_z clip mode opacity contours contvalues
Inserts a section.
"name" is a string containing the name of the section.
dir_x, dir_y, dir_z are floating point values that specify the normal to the sectioning plane.
orig_x, orig_y, orig_z are floating point values that specify one point on the sectioning plane.
clip is an integer value that specifies if contours clipping is on or off (0 = off, 1 = on).
mode is an integer value that specifies the section mode (1 = contours, 2 = cell scalars, 3 = node scalars).
opacity is an integer value that specifies the opacity of the visual item (0 <= opacity <= 10).
contours is an integer value that specifies if contour lines are shown or not (0 = off, 1 = on).
contvalues is an integer value that specifies if contour values are shown or not (0 = off, 1 = on).
ISOSURFACE "name" isovalue opacity
Inserts an isosurface.
"name" is a string containing the name of the isosurface.
isovalue is a floating point value that specifies the surface's isovalue.
opacity is an integer value that specifies the opacity of the visual item (0 <= opacity <= 100).
VOLUME "name" min max opacity
Inserts a volume containing the subdomain in the range (min, max).
"name" is a string containing the name of the volume.
min, max are floating point values that specify the range.
opacity is an integer value that specifies the opacity of the visual item (0 <= opacity <= 100).
POV x y z
Specifies the point of view (POV).
x, y, z are floating point values that specify the point of view.
FP x y z
Specifies the focal point (FP).
x, y, z are floating point values that specify the focal point.
VIEWUP x y z
Specifies the view up vector.
x, y, z are floating point values that specify the up vector.
VIEW "name" pov_x pov_y pov_z focus_x focus_y focus_z up_x up_y up_z
Inserts a view in the view list
"name" is the name of the view
pov_x, pov_y, pov_z are floating point values that specify the point of view.
focus_x, focus_y, focus_z are floating point values that specify the focal point.
up_x, up_y, up_z are floating point values that specify the up vector.
SLEEP t
Inserts a delay in the execution of the script.
t is an integer value that specifies the delay in milliseconds.
SCALARBAR visible
Sets the visibility of scalar bar.
visible is an integer value that specifies whether the scalar bar is visible or not (0 = off, 1 = on).
AXES visible v_ticks v_labels v_titles ticks_x ticks_y ticks_z dec_digits r g b size
Sets the visibility of axes.
visible is an integer value that specifies whether axes are visible or not (0 = off, 1 = on).
v_ticks, v_labels, v_titles are integer values that specify whether ticks, labels and titles are visible or not (0 =
off, 1 = on).
ticks_x, ticks_y, ticks_z are positive integer values that specify the number of ticks for x, y and z axes
respectively.
dec_digits is a positive integer value that specifies the number of decimal digits shown in labels.
r, g, b are positive integer values that specify the color of axes (0 <= r,g,b <= 255).
size is a positive integer value that specifies the size of labels and titles (1 <= size <= 5).
ELECTRODES visible
Sets the visibility of electrodes.
visible is an integer value that specifies whether electrodes are visible or not (0 = off, 1 = on).
RANGE min max
Changes the scalar bar range to (min, max).
min, max are floating point values that specify the new scalar range.
FILTERS visible x y
Sets the visibility of filters dialog box.
visible is an integer value that specifies whether dialog box is visible or not (0 = off, 1 = on).
x, y are floating point values that specify the top-left corner of the dialog box (x and y are normalized to the
main window's size and relative to its top left corner).
PERSPECTIVE on
Sets perspective on or off
on is an integer value that specifies whether perspective is on or off (0 = off, 1 = on).
LABEL "name" x y z r g b size
Inserts a label.
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"name" is a string containing the name of the label.
x, y, z are floating point values that specify the position of the label.
r, g, b are positive integer values that specify the color of the label (0 <= r,g,b <= 255).
size is a positive integer value that specifies the size of the label (0 <= size <= 10).
CAPTUREBMP "filename"
Captures a screenshot in a bitmap file.
"filename" is a string containing the name of the bitmap file.
EXIT
Closes the application.
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